LogoopenSUSE Build Service > Projects
Sign Up | Log In

Conversion between markup formats

Pandoc is a Haskell library for converting from one markup format to another, and a command-line tool that uses this library. It can read markdown and (subsets of) reStructuredText, HTML, and LaTeX, and it can write markdown, reStructuredText, HTML, LaTeX, ConTeXt, Docbook, OpenDocument, ODT, RTF, MediaWiki, groff man pages, and S5 HTML slide shows.

Pandoc extends standard markdown syntax with footnotes, embedded LaTeX, definition lists, tables, and other features. A compatibility mode is provided for those who need a drop-in replacement for Markdown.pl. 

In contrast to existing tools for converting markdown to HTML, which use regex substitutions, pandoc has a modular design: it consists of a set of readers, which parse text in a given format and produce a native representation of the document, and a set of writers, which convert this native representation into a target format. Thus, adding an input or output format requires only adding a reader or writer.

Source Files (show merged sources derived from linked package)

Filename Size Changed Actions
pandoc-2.2.1.tar.gz 8.58 MB 13 days ago
pandoc-pdf.readme 130 Bytes over 2 years ago Download File
pandoc.changes 287 KB 2 days ago Download File
pandoc.spec 15.1 KB 2 days ago Download File

Comments for devel:languages:haskell (2)

Repo Checker repo-checker wrote 9 months ago

The version of this package in openSUSE:Factory has installation issues and may not be installable:

can't install ghc-pandoc-1.19.2.1-6.6.i586:
  nothing provides liblua.so.5.1 needed by ghc-pandoc-1.19.2.1-6.6.i586

can't install ghc-pandoc-1.19.2.1-6.6.x86_64:
  nothing provides liblua.so.5.1()(64bit) needed by ghc-pandoc-1.19.2.1-6.6.x86_64

can't install ghc-pandoc-devel-1.19.2.1-6.6.i586:
  package ghc-pandoc-devel-1.19.2.1-6.6.i586 requires ghc-pandoc = 1.19.2.1-6.6, but none of the providers can be installed
  nothing provides liblua.so.5.1 needed by ghc-pandoc-1.19.2.1-6.6.i586

can't install ghc-pandoc-devel-1.19.2.1-6.6.x86_64:
  package ghc-pandoc-devel-1.19.2.1-6.6.x86_64 requires ghc-pandoc = 1.19.2.1-6.6, but none of the providers can be installed
  nothing provides liblua.so.5.1()(64bit) needed by ghc-pandoc-1.19.2.1-6.6.x86_64

can't install pandoc-1.19.2.1-6.6.i586:
  nothing provides liblua.so.5.1 needed by pandoc-1.19.2.1-6.6.i586

can't install pandoc-1.19.2.1-6.6.x86_64:
  nothing provides liblua.so.5.1()(64bit) needed by pandoc-1.19.2.1-6.6.x86_64

can't install pandoc-pdf-1.19.2.1-6.6.i586:
  package pandoc-pdf-1.19.2.1-6.6.i586 requires pandoc = 1.19.2.1, but none of the providers can be installed
  nothing provides liblua.so.5.1 needed by pandoc-1.19.2.1-6.6.i586

can't install pandoc-pdf-1.19.2.1-6.6.x86_64:
  package pandoc-pdf-1.19.2.1-6.6.x86_64 requires pandoc = 1.19.2.1, but none of the providers can be installed
  nothing provides liblua.so.5.1()(64bit) needed by pandoc-1.19.2.1-6.6.x86_64

Repo Checker repo-checker wrote 3 months ago

The version of this package in openSUSE:Leap:15.0 has installation issues and may not be installable:

can't install ghc-pandoc-devel-1.19.2.1-lp150.1.10.x86_64:
  package ghc-compiler-8.0.2-lp150.1.10.x86_64 requires gcc, but none of the providers can be installed
  package ghc-pandoc-devel-1.19.2.1-lp150.1.10.x86_64 requires ghc-compiler = 8.0.2, but none of the providers can be installed
  package gcc-7-lp150.1.27.x86_64 requires gcc7, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-7.3.0+r257042-lp150.1.3.x86_64

can't install pandoc-pdf-1.19.2.1-lp150.1.10.x86_64:
  package texlive-upquote-2017.133.1.3svn26059-lp150.4.2.noarch requires tex(textcomp.sty), but none of the providers can be installed
  package texlive-latex-2017.133.20170101_pl1svn43813-lp150.5.2.noarch requires texlive-luatex >= 2017, but none of the providers can be installed
  package pandoc-pdf-1.19.2.1-lp150.1.10.x86_64 requires texlive-upquote, but none of the providers can be installed
  package texlive-luatex-2017.133.svn44166-lp150.4.2.noarch requires texlive-luatex-bin >= 2017, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by texlive-luatex-bin-2017.20170520.svn44549-lp150.7.1.x86_64