Edit Package perl-Dancer2-Plugin-Auth-Extensible

Extensible authentication framework for Dancer2 apps

https://metacpan.org/release/Dancer2-Plugin-Auth-Extensible

A user authentication and authorisation framework plugin for Dancer2 apps.

Makes it easy to require a user to be logged in to access certain routes,
provides role-based access control, and supports various authentication
methods/sources (config file, database, Unix system users, etc).

Designed to support multiple authentication realms and to be as extensible
as possible, and to make secure password handling easy. The base class for
auth providers makes handling 'RFC2307'-style hashed passwords really
simple, so you have no excuse for storing plain-text passwords. A simple
script called *dancer2-generate-crypted-password* to generate RFC2307-style
hashed passwords is included, or you can use Crypt::SaltedHash yourself to
do so, or use the 'slappasswd' utility if you have it installed.

Refresh
Refresh
Source Files (show merged sources derived from linked package)
Filename Size Changed
Dancer2-Plugin-Auth-Extensible-0.710.tar.gz 0000062846 61.4 KB over 1 year
cpanspec.yml 0000000933 933 Bytes about 1 year
perl-Dancer2-Plugin-Auth-Extensible.changes 0000000609 609 Bytes over 1 year
perl-Dancer2-Plugin-Auth-Extensible.spec 0000004091 4 KB about 1 year
remove-env-perl.patch 0000000302 302 Bytes over 2 years
Comments 0
openSUSE Build Service is sponsored by