LogoopenSUSE Build Service > Projects
Sign Up | Log In

A powerful implementaion of MPI2

Open MPI is a project combining technologies and resources from several
other projects (FT-MPI, LA-MPI, LAM/MPI, and PACX-MPI) in order to
build the best MPI library available.

This RPM contains all the tools necessary to compile, link, and run
Open MPI jobs.

Source Files (show merged sources derived from linked package)

Filename Size Changed Actions
_multibuild 156 Bytes about 1 year ago Download File
_service 705 Bytes 6 months ago Download File
fix-rdma-component-selection.patch 1.56 KB 6 months ago Download File
macros.hpc-openmpi 626 Bytes about 1 month ago Download File
mpivars.csh 318 Bytes about 1 year ago Download File
mpivars.sh 526 Bytes about 1 year ago Download File
openmpi-2.1.3.0.cfd8f3f34e27.tar.bz2 4.98 MB 6 months ago
openmpi2-add-HCAs-to-mca-ini.patch 949 Bytes 4 months ago Download File
openmpi2-rpmlintrc 187 Bytes over 1 year ago Download File
openmpi2.changes 10.2 KB 10 days ago Download File
openmpi2.spec 20.7 KB 4 days ago Download File

Comments for science:HPC (2)

repo-checker wrote about 1 year ago

The version of this package in openSUSE:Factory has installation issues and may not be installable:

can't install openmpi2-libs-32bit-2.1.1-2.3.x86_64:
  nothing provides libfabric.so.1 needed by openmpi2-libs-32bit-2.1.1-2.3.x86_64
  nothing provides libfabric.so.1(FABRIC_1.0) needed by openmpi2-libs-32bit-2.1.1-2.3.x86_64

repo-checker wrote 7 months ago

The version of this package in openSUSE:Leap:15.0 has installation issues and may not be installable:

can't install openmpi2-gnu-hpc-devel-2.1.2-lp150.5.1.noarch:
  package openmpi_2_1_2-gnu-hpc-devel-2.1.2-lp150.5.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package openmpi2-gnu-hpc-devel-2.1.2-lp150.5.1.noarch requires openmpi_2_1_2-gnu-hpc-devel = 2.1.2, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install openmpi2-gnu-hpc-devel-static-2.1.2-lp150.5.1.x86_64:
  package openmpi_2_1_2-gnu-hpc-devel-2.1.2-lp150.5.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package openmpi_2_1_2-gnu-hpc-devel-static-2.1.2-lp150.5.1.x86_64 requires openmpi_2_1_2-gnu-hpc-devel = 2.1.2, but none of the providers can be installed
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package openmpi2-gnu-hpc-devel-static-2.1.2-lp150.5.1.x86_64 requires openmpi_2_1_2-gnu-hpc-devel-static = 2.1.2, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install openmpi2-gnu-hpc-macros-devel-2.1.2-lp150.5.1.noarch:
  package openmpi_2_1_2-gnu-hpc-devel-2.1.2-lp150.5.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package openmpi_2_1_2-gnu-hpc-macros-devel-2.1.2-lp150.5.1.x86_64 requires openmpi_2_1_2-gnu-hpc-devel = 2.1.2, but none of the providers can be installed
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package openmpi2-gnu-hpc-macros-devel-2.1.2-lp150.5.1.noarch requires openmpi_2_1_2-gnu-hpc-macros-devel = 2.1.2, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install openmpi_2_1_2-gnu-hpc-devel-2.1.2-lp150.5.1.x86_64:
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package openmpi_2_1_2-gnu-hpc-devel-2.1.2-lp150.5.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install openmpi_2_1_2-gnu-hpc-devel-static-2.1.2-lp150.5.1.x86_64:
  package openmpi_2_1_2-gnu-hpc-devel-2.1.2-lp150.5.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package openmpi_2_1_2-gnu-hpc-devel-static-2.1.2-lp150.5.1.x86_64 requires openmpi_2_1_2-gnu-hpc-devel = 2.1.2, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install openmpi_2_1_2-gnu-hpc-macros-devel-2.1.2-lp150.5.1.x86_64:
  package openmpi_2_1_2-gnu-hpc-devel-2.1.2-lp150.5.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package openmpi_2_1_2-gnu-hpc-macros-devel-2.1.2-lp150.5.1.x86_64 requires openmpi_2_1_2-gnu-hpc-devel = 2.1.2, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

Login required, please login or signup in order to comment