LogoopenSUSE Build Service > Projects
Sign Up | Log In

View File geoclue.changes of Package geoclue (Project Application:Geo)

-------------------------------------------------------------------
Wed Mar 27 07:42:48 UTC 2013 - mmeister@suse.com

- Added url as source.
  Please see http://en.opensuse.org/SourceUrls

-------------------------------------------------------------------
Mon Oct 22 15:32:46 UTC 2012 - bruno@ioda-net.ch

- Update to last upstream stable 0.12.99 which build fine on factory 
- Removed all upstream included patch
- Fix fsf address

-------------------------------------------------------------------
Tue Jan 31 10:02:26 UTC 2012 - vuntz@opensuse.org

- Add geoclue-glib-2.31.patch: fix build with glib 2.31.

-------------------------------------------------------------------
Sat Oct  1 05:39:12 UTC 2011 - coolo@suse.com

- add libtool as buildrequire to make the spec file more reliable

-------------------------------------------------------------------
Wed May  4 15:22:25 UTC 2011 - idoenmez@novell.com

- Add geoclue-use-libnm-glib.patch: use networkmanager glib interface
- Drop gpsd support, it doesn't compile 
- Add geoclue-0.12.0-gcc46.patch: remove write-only variable

-------------------------------------------------------------------
Fri Sep 10 14:52:37 CEST 2010 - vuntz@opensuse.org

- Fix build on 11.2 and earlier.

-------------------------------------------------------------------
Fri Jun  4 12:54:20 UTC 2010 - coolo@novell.com

- add baselibs.conf

-------------------------------------------------------------------
Fri Mar 26 23:39:17 CET 2010 - vuntz@opensuse.org

- Update to version 0.12.0:
  + add Geocode.FreeformAddressToPosition()-method
  + add Nominatim (OpenStreetMap) geocoder/revgeocoder
  + gsmloc provider: stop using gammu, start using ofono
  + don't do horrible shell script calls in providers
  + example improvements
  + hostip api update
  + gpsd api update
  + use opencellid.org instead of gsmloc.org
  + Master Client: add Invalidated signal when the dbus client
    object dies
  + bug fixes
- Drop geoclue-gammu-api.patch, and remove gammu-devel
  BuildRequires: the gammu dependency was dropped.
- Add geoclue-nm08.patch to fix build against NetworkManager 0.8,
  thanks to Fedora. Add gtk-doc BuildRequires and call to
  autoreconf for it.
- Add libsoup-devel BuildRequires to build the skyhook provider.
- Remove SUSE_ASNEEDED=0: it's not needed anymore.
- Manually install geoclue-test-gui since it's not installed
  by default anymore.

-------------------------------------------------------------------
Thu Jul 30 15:38:40 CEST 2009 - vuntz@novell.com

- Export SUSE_ASNEEDED=0 to fix build.

-------------------------------------------------------------------
Wed Jun 17 17:54:04 CEST 2009 - vuntz@novell.com

- Initial package.