LogoopenSUSE Build Service > Projects
Sign Up | Log In

View File libbonobo.spec of Package libbonobo (Project GNOME:Factory)

# spec file for package libbonobo
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/

Name:           libbonobo
BuildRequires:  bison
BuildRequires:  fdupes
BuildRequires:  flex
BuildRequires:  glib2-devel
BuildRequires:  gtk-doc
BuildRequires:  intltool
BuildRequires:  libxml2-devel
BuildRequires:  orbit2-devel
BuildRequires:  popt-devel
BuildRequires:  translation-update-upstream
Summary:        The Bonobo Component System for the GNOME 2.x Desktop Platform
License:        GPL-2.0+ and LGPL-2.1+
Group:          Development/Libraries/GNOME
Version:        2.32.1
Release:        0
# Obsolete for >=9.1:
Obsoletes:      bonobo-activation
Provides:       bonobo-activation
# bug437293
%ifarch ppc64
Obsoletes:      libbonobo-64bit
Source:         http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.32/%{name}-%{version}.tar.bz2
Source99:       baselibs.conf
Url:            http://www.gnome.org/
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Patch2:         bonobo-activation-config.patch
# PATCH-FIX-OPENSUSE libbonobo-lib64.patch vuntz@opensuse.org -- Handle libdir in addition to libexecdir on 64-bit machines for .server files
Patch3:         libbonobo-lib64.patch
# PATCH-FEATURE-OPENSUSE libbonobo-fate300461-server-gettext.patch fate300461 vuntz@novell.com -- Look for translation of .server files via gettext
Patch4:         libbonobo-fate300461-server-gettext.patch
Recommends:     %{name}-lang = %{version}

Bonobo is a component system for the GNOME platform. Libbonobo is the
new version for the GNOME 2.x Desktop platform.

%package devel
Summary:        Include Files and Libraries mandatory for Development.
Group:          Development/Libraries/GNOME
Requires:       %{name} = %{version}
Requires:       glib2-devel
Requires:       orbit2-devel
Requires:       popt-devel
# Obsolete for >=9.1:
Obsoletes:      bonobo-activation-devel
Provides:       bonobo-activation-devel
# bug437293
%ifarch ppc64
Obsoletes:      libbonobo-devel-64bit

%description devel
This package contains all necessary include files and libraries needed
to develop applications that require these.

%package doc
Summary:        Additional Package Documentation.
Group:          Development/Libraries/GNOME
Requires:       %{name} = %{version}
# Obsolete for >=9.1:
Obsoletes:      bonobo-activation-doc
Provides:       bonobo-activation-doc

%description doc
Bonobo is a component system for the GNOME platform. Libbonobo is the
new version for the GNOME 2.x platform.

%setup -q
%if "%{_lib}" == "lib64"
%patch3 -p1
%patch4 -p1

%configure --with-pic\
echo "#undef G_DISABLE_DEPRECATED" >> config.h
# Do not use parallel build.. to many random fallouts
make -j1

%if 0%{?suse_version} <= 1120
%{__rm} %{buildroot}%{_datadir}/locale/en@shaw/LC_MESSAGES/*
find %{buildroot}%{_libdir} -name '*.la' -type f -delete -print
%if "%{_lib}" == "lib64"
# we need to create the arch-independent directory for .servers file
install -d %{buildroot}%{_libexecdir}/bonobo/servers
%find_lang libbonobo-2.0


%post -p /sbin/ldconfig

%postun -p /sbin/ldconfig

%if "%{_libdir}" != "%{_libexecdir}"
%doc %{_mandir}/man?/*.*
%dir %{_sysconfdir}/bonobo-activation
%config %{_sysconfdir}/bonobo-activation/bonobo-activation-config.xml

%files lang -f libbonobo-2.0.lang

%files devel

%files doc
%dir %{_libdir}/bonobo-2.0