File e1b01186f8a.patch of Package gnome-latex

From e1b01186f8a4e5d3fee4c9ccfbedd6d098517df9 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?S=C3=A9bastien=20Wilmet?= <swilmet@gnome.org>
Date: Fri, 20 Nov 2020 15:46:36 +0100
Subject: [PATCH] Port to Tepl 6 (currently 5.99.0, from git master)

---
 README                      | 2 +-
 configure.ac                | 4 ++--
 src/Makefile.am             | 2 +-
 src/document.vala           | 2 +-
 src/liblatexila/Makefile.am | 4 ++--
 5 files changed, 7 insertions(+), 7 deletions(-)

diff --git a/README b/README
index ed0faf7..0dc67d9 100644
--- a/README
+++ b/README
@@ -21,7 +21,7 @@ Dependencies
 * GLib >= 2.56
 * GTK >= 3.22
 * GtkSourceView >= 4.0
-* Tepl >= 5.0 - https://wiki.gnome.org/Projects/Tepl
+* Tepl >= 5.99 - https://wiki.gnome.org/Projects/Tepl
 * gspell >= 1.8
 * gee-0.8 >= 0.10
 * gsettings-desktop-schemas
diff --git a/configure.ac b/configure.ac
index 743a7da..66d5719 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,7 +32,7 @@ GLIB_REQUIRED_VERSION="2.56"
 GTK_REQUIRED_VERSION="3.22"
 GTKSOURCEVIEW_REQUIRED_VERSION="4.0"
 AMTK_REQUIRED_VERSION="5.2"
-TEPL_REQUIRED_VERSION="5.0"
+TEPL_REQUIRED_VERSION="5.99"
 GSPELL_REQUIRED_VERSION="1.8"
 VALA_REQUIRED_VERSION="0.46"
 GEE_REQUIRED_VERSION="0.10"
@@ -96,7 +96,7 @@ PKG_CHECK_MODULES([DEP], [
 	gtk+-3.0 >= ${GTK_REQUIRED_VERSION}
 	gtksourceview-4 >= ${GTKSOURCEVIEW_REQUIRED_VERSION}
 	amtk-5 >= ${AMTK_REQUIRED_VERSION}
-	tepl-5 >= ${TEPL_REQUIRED_VERSION}
+	tepl-6 >= ${TEPL_REQUIRED_VERSION}
 	gspell-1 >= ${GSPELL_REQUIRED_VERSION}
 	gee-0.8 >= ${GEE_REQUIRED_VERSION}
 	gsettings-desktop-schemas
diff --git a/src/Makefile.am b/src/Makefile.am
index 636ca25..73f5a9a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -8,7 +8,7 @@ AM_VALAFLAGS =					\
 	--disable-since-check			\
 	--pkg gtk+-3.0				\
 	--pkg gtksourceview-4			\
-	--pkg Tepl-5				\
+	--pkg Tepl-6				\
 	--pkg gspell-1				\
 	--pkg gee-0.8				\
 	--pkg posix				\
diff --git a/src/document.vala b/src/document.vala
index 520945d..f3afa35 100644
--- a/src/document.vala
+++ b/src/document.vala
@@ -224,7 +224,7 @@ public class Document : Tepl.Buffer
                     string primary_msg = _("Impossible to save the file.");
                     Tepl.InfoBar infobar = new Tepl.InfoBar.simple (MessageType.ERROR,
                         primary_msg, e.message);
-                    infobar.add_close_button ();
+                    infobar.setup_close_button ();
                     tab.add_info_bar (infobar);
                     infobar.show ();
                 }
diff --git a/src/liblatexila/Makefile.am b/src/liblatexila/Makefile.am
index b4e53b5..25c20a9 100644
--- a/src/liblatexila/Makefile.am
+++ b/src/liblatexila/Makefile.am
@@ -135,7 +135,7 @@ INTROSPECTION_GIRS = Latexila.gir
 
 Latexila.gir: liblatexila.la
 Latexila_gir_NAMESPACE = Latexila
-Latexila_gir_INCLUDES = Gtk-3.0 GtkSource-4 Tepl-5
+Latexila_gir_INCLUDES = Gtk-3.0 GtkSource-4 Tepl-6
 Latexila_gir_LIBS = liblatexila.la
 Latexila_gir_FILES =				\
 	$(liblatexila_public_headers)		\
@@ -156,7 +156,7 @@ latexila.vapi: Latexila.gir
 
 VAPIGEN_VAPIS = latexila.vapi
 
-latexila_vapi_DEPS = gio-2.0 gtk+-3.0 gtksourceview-4 Tepl-5
+latexila_vapi_DEPS = gio-2.0 gtk+-3.0 gtksourceview-4 Tepl-6
 latexila_vapi_FILES = Latexila.gir
 
 noinst_DATA += latexila.vapi
-- 
GitLab
openSUSE Build Service is sponsored by