File gnome-software.spec of Package gnome-software

#
# spec file for package gnome-software
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           gnome-software
Version:        3.16.6
Release:        0
%define gs_plugin_api 7
Summary:        GNOME Software Store
License:        GPL-2.0+
Group:          System/GUI/GNOME
Url:            https://wiki.gnome.org/Design/Apps/Software
Source:         http://download.gnome.org/sources/gnome-software/3.16/%{name}-%{version}.tar.xz
# PATCH-FEATURE-OPENSUSE gnome-software-PK-updates.patch dimstar@opensuse.org -- Switch to PackageKit Update provider instead of systemd offline updates.
Patch0:         gnome-software-PK-updates.patch
# PATCH-FEATURE-OPENSUSE gnome-software-add-default-yast-appfolder.patch boo#897713 badshah400@gmail.com -- Adds a YaST app-folder by default, in addition to existing app-folders Sundry and Utilities
Patch1:         gnome-software-add-default-yast-appfolder.patch
# PATCH-FIX-OPENSUSE gnome-software-nouser-proxy.patch dimstar@opensuse.org -- Do not pass user settings between the user session and packagekitd
Patch100:       gnome-software-nouser-proxy.patch
# PATCH-FIX-OPENSUSE gnome-software-xterm-is-not-removable.patch boo#906598 dimstar@opensuse.org -- XTerm is a system dependency and must not be removable
Patch101:       gnome-software-xterm-is-not-removable.patch
BuildRequires:  intltool >= 0.35.0
BuildRequires:  suse-xsl-stylesheets
BuildRequires:  update-desktop-files
BuildRequires:  pkgconfig(appstream-glib) >= 0.3.4
BuildRequires:  pkgconfig(gio-unix-2.0)
BuildRequires:  pkgconfig(gnome-desktop-3.0)
BuildRequires:  pkgconfig(gsettings-desktop-schemas) >= 3.11.5
BuildRequires:  pkgconfig(gtk+-3.0) >= 3.16
BuildRequires:  pkgconfig(libsoup-2.4)
BuildRequires:  pkgconfig(libxslt)
BuildRequires:  pkgconfig(packagekit-glib2) >= 1.0.0
BuildRequires:  pkgconfig(polkit-gobject-1)
BuildRequires:  pkgconfig(sqlite3)
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Requires:       iso-codes
Requires:       libzypp-plugin-appdata
Recommends:     %{name}-lang
%glib2_gsettings_schema_requires

%description
AppStore like management of Applications for your GNOME Desktop.

%lang_package

%prep
%setup -q
# Disables - let's try the systemd offline updater
#patch0 -p1
%patch1 -p1
%patch100 -p1
%patch101 -p1

%build
%configure \
    --disable-static
make %{?_smp_mflags}

%install
%make_install
find %{buildroot}%{_libdir} -type f -name '*.la' -delete -print
# Currently not shipped, as this is not yet functional (boo#941862)
rm %{buildroot}%{_datadir}/applications/gnome-software-local-file.desktop
#suse_update_desktop_file gnome-software
%find_lang %{name}

%post
%glib2_gsettings_schema_post
%icon_theme_cache_post
%desktop_database_post

%postun
%glib2_gsettings_schema_postun
%icon_theme_cache_postun
%desktop_database_postun

%files
%defattr(-,root,root)
%doc README COPYING
%{_bindir}/%{name}
%{_datadir}/%{name}/
%dir %{_datadir}/appdata
%{_datadir}/appdata/org.gnome.Software.appdata.xml
# Currently not shipped, as this is not yet functional (boo#941862)
#{_datadir}/applications/gnome-software-local-file.desktop
%{_datadir}/applications/org.gnome.Software.desktop
%{_datadir}/dbus-1/services/org.gnome.Software.service
%{_datadir}/glib-2.0/schemas/org.gnome.software.gschema.xml
%dir %{_datadir}/gnome-shell
%dir %{_datadir}/gnome-shell/search-providers
%{_datadir}/gnome-shell/search-providers/gnome-software-search-provider.ini
%{_datadir}/icons/hicolor/*/apps/%{name}*
%dir %{_libdir}/gs-plugins-%{gs_plugin_api}
%{_libdir}/gs-plugins-%{gs_plugin_api}/*.so
#{_libexecdir}/gnome-software-service
%{_mandir}/man1/%{name}.1%{?ext_man}
%{_sysconfdir}/xdg/autostart/gnome-software-service.desktop

%files lang -f %{name}.lang

%changelog
openSUSE Build Service is sponsored by