LogoopenSUSE Build Service > Projects
Sign Up | Log In

View File 04_enable_debug_information.diff of Package libQtWebKit4 (Project KDE:Qt)

diff -urNB orig.webkit-qtwebkit-23/Source/JavaScriptCore/JavaScriptCore.pri webkit-qtwebkit-23/Source/JavaScriptCore/JavaScriptCore.pri
--- orig.webkit-qtwebkit-23/Source/JavaScriptCore/JavaScriptCore.pri	2013-03-14 14:24:37.000000000 +0100
+++ webkit-qtwebkit-23/Source/JavaScriptCore/JavaScriptCore.pri	2013-04-08 19:44:20.232097452 +0200
@@ -7,6 +7,12 @@
 
 SOURCE_DIR = $${ROOT_WEBKIT_DIR}/Source/JavaScriptCore
 
+equals(QT_ARCH, arm) {
+    message("JavaScriptCore workaround for QtWebkit: do not build with -g, but with -g1")
+    QMAKE_CXXFLAGS_RELEASE -= -g
+    QMAKE_CXXFLAGS_RELEASE += -g1
+}
+
 JAVASCRIPTCORE_GENERATED_SOURCES_DIR = $${ROOT_BUILD_DIR}/Source/JavaScriptCore/$${GENERATED_SOURCES_DESTDIR}
 
 INCLUDEPATH += \
diff -urNB orig.webkit-qtwebkit-23/Source/WebCore/WebCore.pri webkit-qtwebkit-23/Source/WebCore/WebCore.pri
--- orig.webkit-qtwebkit-23/Source/WebCore/WebCore.pri	2013-03-14 14:24:37.000000000 +0100
+++ webkit-qtwebkit-23/Source/WebCore/WebCore.pri	2013-04-08 19:45:23.002312717 +0200
@@ -7,6 +7,12 @@
 
 SOURCE_DIR = $${ROOT_WEBKIT_DIR}/Source/WebCore
 
+equals(QT_ARCH, arm)|equals(QT_ARCH, i386)|equals(QT_ARCH, i686)|equals(QT_ARCH, x86_64)| equals(QT_ARCH, powerpc64)|equals(QT_ARCH, powerpc) {
+    message("WebCore workaround for QtWebkit: do not build with -g, but with -g1")
+    QMAKE_CXXFLAGS_RELEASE -= -g
+    QMAKE_CXXFLAGS_RELEASE += -g1
+}
+
 QT *= network
 haveQt(5): QT *= core-private gui-private
 
diff -urNB orig.webkit-qtwebkit-23/Source/WebKit/WebKit1.pri webkit-qtwebkit-23/Source/WebKit/WebKit1.pri
--- orig.webkit-qtwebkit-23/Source/WebKit/WebKit1.pri	2013-03-14 14:24:37.000000000 +0100
+++ webkit-qtwebkit-23/Source/WebKit/WebKit1.pri	2013-04-08 19:46:41.045337045 +0200
@@ -7,6 +7,12 @@
 
 SOURCE_DIR = $${ROOT_WEBKIT_DIR}/Source/WebKit
 
+equals(QT_ARCH, arm) {
+    message("WebKit1 workaround for QtWebkit: do not build with -g, but with -g1")
+    QMAKE_CXXFLAGS_RELEASE -= -g
+    QMAKE_CXXFLAGS_RELEASE += -g1
+}
+
 INCLUDEPATH += \
     $$SOURCE_DIR/qt/Api \
     $$SOURCE_DIR/qt/WebCoreSupport \
diff -urNB orig.webkit-qtwebkit-23/Source/WTF/WTF.pri webkit-qtwebkit-23/Source/WTF/WTF.pri
--- orig.webkit-qtwebkit-23/Source/WTF/WTF.pri	2013-03-14 14:24:37.000000000 +0100
+++ webkit-qtwebkit-23/Source/WTF/WTF.pri	2013-04-08 19:46:46.301271336 +0200
@@ -8,6 +8,12 @@
 # All external modules should include WTF headers by prefixing with "wtf" (#include <wtf/some/thing.h>).
 INCLUDEPATH += $$PWD
 
+equals(QT_ARCH, arm) {
+    message("WTF workaround for QtWebkit: do not build with -g, but with -g1")
+    QMAKE_CXXFLAGS_RELEASE -= -g
+    QMAKE_CXXFLAGS_RELEASE += -g1
+}
+
 haveQt(5) {
     mac {
         # Mac OS does ship libicu but not the associated header files.