LogoopenSUSE Build Service > Projects
Sign Up | Log In

View File system-poppler-0.12.3.diff of Package libreoffice-icon-themes (Project LibreOffice:Stable)

diff -urN libreoffice-4.1.0.0.beta1.old/configure.ac libreoffice-4.1.0.0.beta1/configure.ac
--- libreoffice-4.1.0.0.beta1.old/configure.ac	2013-05-27 14:04:19.684304208 +0200
+++ libreoffice-4.1.0.0.beta1/configure.ac	2013-05-29 12:27:28.212284282 +0200
@@ -9658,16 +9658,6 @@
       AC_MSG_RESULT([external])
       SYSTEM_POPPLER=YES
       PKG_CHECK_MODULES( POPPLER, poppler >= 0.8.0 )
-      AC_LANG_PUSH([C++])
-      save_CXXFLAGS=$CXXFLAGS
-      save_CPPFLAGS=$CPPFLAGS
-      CXXFLAGS="$CXXFLAGS $POPPLER_CFLAGS"
-      CPPFLAGS="$CPPFLAGS $POPPLER_CFLAGS"
-      AC_CHECK_HEADER([cpp/poppler-version.h], [],
-                   [AC_MSG_ERROR([cpp/poppler-version.h not found. Install poppler])], [])
-      CXXFLAGS=$save_CXXFLAGS
-      CPPFLAGS=$save_CPPFLAGS
-      AC_LANG_POP([C++])
       libo_MINGW_CHECK_DLL([libpoppler])
   else
       AC_MSG_RESULT([internal])
diff -urN libreoffice-4.1.0.0.beta1.old/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx libreoffice-4.1.0.0.beta1/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
--- libreoffice-4.1.0.0.beta1.old/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx	2013-05-27 14:04:19.863304208 +0200
+++ libreoffice-4.1.0.0.beta1/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx	2013-05-29 12:25:26.574284296 +0200
@@ -58,7 +58,10 @@
 #define POPPLER_CHECK_VERSION(major,minor,micro) (0)
 typedef GString GooString;
 #else
-#include <cpp/poppler-version.h>
+#define POPPLER_VERSION "0.12.3"
+#define POPPLER_VERSION_MAJOR 0
+#define POPPLER_VERSION_MINOR 12
+#define POPPLER_VERSION_MICRO 3
 #define POPPLER_CHECK_VERSION(major,minor,micro) \
   (POPPLER_VERSION_MAJOR > (major) || \
    (POPPLER_VERSION_MAJOR == (major) && POPPLER_VERSION_MINOR > (minor)) || \