File phantomjs.changes of Package phantomjs

-------------------------------------------------------------------
Wed Nov 29 01:58:30 UTC 2017 - qantas94heavy@gmail.com

- Explicitly require OpenSSL 1.0 for build due to change to
  OpenSSL 1.1 as default for Tumbleweed and Leap 15

-------------------------------------------------------------------
Wed May 31 08:29:50 UTC 2017 - qantas94heavy@gmail.com

- Add qt5-webkit-icu59.patch:
  * Fix build with ICU 59 (boo#1041280)

-------------------------------------------------------------------
Tue Jan 24 16:38:04 UTC 2017 - msuchanek@suse.com

 Bump build requirement to 8GB ram.
 The package fails to build in IBS on particular hosts with gcc crashing and
 the only obvious difference between the failing and successful hosts is RAM
 amount.

-------------------------------------------------------------------
Fri Dec  9 10:55:21 UTC 2016 - qantas94heavy@gmail.com

- Downgrade phantomjs to 2.1.1
  * Fixes issue where PhantomJS crashes on startup (boo#1008760)
- Add unset-QT_QPA_PLATFORM.patch:
  * Stops PhantomJS crashing due to wrong Qt plugin type used
- Remove disable-webkit-dir-error.patch:
  * Not applicable to this version of phantomjs.

-------------------------------------------------------------------
Wed Dec  7 13:37:08 UTC 2016 - qantas94heavy@gmail.com

- Update to latest commit on master branch (ec2966b)
  * Fixes "phantom" Qt plugin crash on startup (boo#1008760)
  * Use system version of Qt (needs 5.6+)
- Add disable-webkit-dir-error.patch:
  * Disable spurious compilation error (only applies to static builds)

-------------------------------------------------------------------
Fri Jul  1 16:50:30 UTC 2016 - toddrme2178@gmail.com

- Fix typo in Group tag.

-------------------------------------------------------------------
Mon May 30 00:59:57 CEST 2016 - ro@suse.de

- update to version 2.1.1+git20160526.6090f54 

-------------------------------------------------------------------
Sun May 29 22:52:45 UTC 2016 - i@marguerite.su

- Update to version 2.1.1+git20160526.6090f54:
  * Disable QPA platform guard
  * Handle QtInfoMsg
  * Fix building with MSVC2015
  * Update QtWebkit module
  * Fixed typo
  * Upgrade example to run with Jasmine 2.4.1
  * Fix 'qt_config' problem.
  * Update request error message.
  * Update build.py to disable qtbase/qtwebkit unwanted features
  * [OS X] Allow building with custom OpenSSL library

-------------------------------------------------------------------
Mon Feb  1 10:21:30 UTC 2016 - i@marguerite.su

- update version 2.1.1+git20160125.482b91d

-------------------------------------------------------------------
Thu Dec 25 12:36:47 UTC 2014 - boris@steki.net

- update to latest release 1.9.8
  + Change default SSL protocol to TLSv1 to address POODLE (issue 12655)
  + Fixed building on OS X 10.10 Yosemite (issue 12622)
  + Backported crash fix when exit (issue 11642, 12431)

-------------------------------------------------------------------
Wed Aug  6 09:42:18 UTC 2014 - toddrme2178@gmail.com

- Update source to point to website
- Minor spec file cleanups
- Update to 1.9.7
  * Reverted to GhostDriver 1.1.0 instead of 1.1.1 (issue 11915)
  * Fixed another warning of obsolete userSpaceScaleFactor on OS X 10.9 (issue 11612)
- Update to 1.9.6
  * Updated GhostDriver to version 1.1.1 (issue 11877, 11893)
- Update to 1.9.3
  * Fixed CoreText performance note on OS X 10.9 (issue 11418)
  * Fixed warning of obsolete userSpaceScaleFactor on OS X 10.9 (issue 11612)
- Update to 1.9.2
  * Fixed graphical artifacts with transparent background on Windows (issue 11276, 11007, 11366)
  * Updated GhostDriver to version 1.0.4 (issue 11452)

-------------------------------------------------------------------
Fri Jul 26 23:06:43 UTC 2013 - boris@steki.net

- updated to version 1.9.1 

-------------------------------------------------------------------
Tue Apr 30 00:00:00 UTC 2013 - heydenberk@gmail.com

- add missing filenames for examples to files section


-------------------------------------------------------------------
Wed Apr 24 00:00:00 UTC 2013 - lobbin@gmail.com

- updated to version 1.9


-------------------------------------------------------------------
Thu Jan 24 00:00:00 UTC 2013 - mbarr@snap-interactive.com

- updated to version 1.8


-------------------------------------------------------------------
Thu Nov 15 00:00:00 UTC 2012 - jschauma@etsy.com

- first rpm version