LogoopenSUSE Build Service > Projects
Sign Up | Log In

View File gummi-deprecated-g_thread_init.patch of Package gummi (Project Publishing)

Index: gummi-0.6.5/src/main.c
===================================================================
--- gummi-0.6.5.orig/src/main.c
+++ gummi-0.6.5/src/main.c
@@ -84,7 +84,13 @@ int main (int argc, char *argv[]) {
     }
 
     /* initialize GTK */
-    g_thread_init (NULL);
+    /* g_thread_init has been deprecated since version 2.32 and
+     * should not be used in newly-written code. This function is
+     * no longer necessary. The GLib threading system is
+     * automatically initialized at the start of your program.
+     * http://developer.gnome.org/glib/2.31/glib-Deprecated-Thread-APIs.html
+     * g_thread_init (NULL); */
+
     gdk_threads_init ();
     gtk_init (&argc, &argv);
     GError* ui_error = NULL;