File _patchinfo of Package patchinfo.11169

<patchinfo incident="11169">
  <issue tracker="bnc" id="1118899">VUL-0: CVE-2018-16875: go: crypto/x509: CPU denial of service</issue>
  <issue tracker="bnc" id="1118898">VUL-0: CVE-2018-16874: go: cmd/go: directory traversal</issue>
  <issue tracker="bnc" id="1118897">VUL-0: CVE-2018-16873: go: cmd/go: remote command execution</issue>
  <issue tracker="bnc" id="1123013">VUL-0: CVE-2019-6486: go: DoS vulnerability in the crypto/elliptic implementations of the P-521 and P-384 elliptic curves</issue>
  <issue tracker="bnc" id="1134068">docker: update to 18.09.5</issue>
  <issue tracker="bnc" id="1128376">L3: CaasP 3.0 worker nodes went into the NotReady State because the PLEG healthcheck</issue>
  <issue tracker="bnc" id="1114832">Running supportconfig on any node can take lots of resources, even fill the hard disk on big/long-running clusters</issue>
  <issue tracker="bnc" id="1128746">Containers module is not available for ARM</issue>
  <issue tracker="bnc" id="1121397">GCC 9: go{1.4,1.9,1.10,1.11} build fails</issue>
  <issue tracker="bnc" id="1114209">go: provides(API) causes "have option" unresolveable builds</issue>
  <issue tracker="cve" id="2018-16873"/>
  <issue tracker="cve" id="2018-16875"/>
  <issue tracker="cve" id="2018-16874"/>
  <issue tracker="cve" id="2019-6486"/>
  <category>security</category>
  <rating>important</rating>
  <packager>cyphar</packager>
  <message>Updating docker will restart the docker service, which may stop some of your docker containers. Do you want to proceed with the update?</message>
  <description>This update for containerd, docker, docker-runc, go, go1.11, go1.12, golang-github-docker-libnetwork fixes the following issues:

Security issues fixed:

- CVE-2019-6486: go security release, fixing crypto/elliptic CPU DoS vulnerability affecting P-521 and P-384 (bsc#1123013).
- CVE-2018-16873: go security release, fixing cmd/go remote command execution (bsc#1118897).
- CVE-2018-16874: go security release, fixing cmd/go directory traversal (bsc#1118898).
- CVE-2018-16875: go security release, fixing crypto/x509 CPU denial of service (bsc#1118899).

Other changes and bug fixes:

- Update to containerd v1.2.5, which is required for v18.09.5-ce (bsc#1128376, boo#1134068).
- Update to runc 2b18fe1d885e, which is required for Docker v18.09.5-ce (bsc#1128376, boo#1134068).
- Update to Docker 18.09.6-ce see upstream changelog in the packaged
- Move daemon.json file to /etc/docker directory (bsc#1114832).
- docker-test: Improvements to test packaging (bsc#1128746).
- Update to go1.11.9 (released 2019/04/11)
- Fix go build failures (bsc#1121397).
- Update to golang-github-docker-libnetwork version git.872f0a83c98add6cae255c8859e29532febc0039 which is required for Docker v18.09.6-ce.
- Revert golang(API) removal since it turns out this breaks &gt;= requires in certain cases (bsc#1114209).
</description>
  <summary>Security update for containerd, docker, docker-runc, go, go1.11, go1.12, golang-github-docker-libnetwork</summary>
</patchinfo>
openSUSE Build Service is sponsored by