File ImageMagick-CVE-2018-14434.patch of Package ImageMagick.8212

diff --git a/coders/mpc.c b/coders/mpc.c
index 6d334bf1c..d0b169f0a 100644
--- a/coders/mpc.c
+++ b/coders/mpc.c
@@ -1440,7 +1440,10 @@ static MagickBooleanType WriteMPCImage(const ImageInfo *image_info,Image *image)
           switch (depth)
           {
             default:
+            {
+              colormap=(unsigned char *) RelinquishMagickMemory(colormap);
               ThrowWriterException(CorruptImageError,"ImageDepthNotSupported");
+            }
             case 32:
             {
               unsigned int