File virt-install-without-generic26.patch of Package cobbler.8146

Index: cobbler-2.6.6/koan/virtinstall.py
===================================================================
--- cobbler-2.6.6.orig/koan/virtinstall.py
+++ cobbler-2.6.6/koan/virtinstall.py
@@ -386,10 +386,7 @@ def build_commandline(uri,
                 # compatibility in virt-install grumble grumble.
                 os_version = os_version + ".0"
             else:
-                if "virtio26" in supported_variants:
-                    os_version = "virtio26"
-                else:
-                    os_version = "generic26"
+                os_version = "virtio26"
                 print("- warning: virt-install doesn't know this os_version, "
                       "defaulting to %s" % os_version)
             cmd += "--os-variant %s " % os_version