File libgcrypt-1.5.0-as-needed.patch of Package compat-libgcrypt11.3673

diff -rNU 20 ../libgcrypt-1.5.0-o/src/Makefile.am ./src/Makefile.am
--- ../libgcrypt-1.5.0-o/src/Makefile.am	2011-05-23 10:07:51.000000000 +0200
+++ ./src/Makefile.am	2011-08-01 16:54:04.000000000 +0200
@@ -93,41 +93,41 @@
 uninstall-def-file:
 
 gcrypt_deps =
 
 endif !HAVE_W32_SYSTEM
 
 
 libgcrypt_la_LDFLAGS = $(no_undefined) $(export_symbols) \
 	$(libgcrypt_version_script_cmd) -version-info \
 	@LIBGCRYPT_LT_CURRENT@:@LIBGCRYPT_LT_REVISION@:@LIBGCRYPT_LT_AGE@
 libgcrypt_la_DEPENDENCIES = \
 	../cipher/libcipher.la \
 	../random/librandom.la \
 	../mpi/libmpi.la \
 	../compat/libcompat.la \
 	$(srcdir)/libgcrypt.vers $(gcrypt_deps)
 libgcrypt_la_LIBADD = $(gcrypt_res) \
 	../cipher/libcipher.la \
 	../random/librandom.la \
 	../mpi/libmpi.la \
-	../compat/libcompat.la  $(GPG_ERROR_LIBS)
+	../compat/libcompat.la  $(GPG_ERROR_LIBS) $(DL_LIBS)
 
 
 dumpsexp_SOURCES = dumpsexp.c
 dumpsexp_CFLAGS = $(arch_gpg_error_cflags)
 dumpsexp_LDADD = $(arch_gpg_error_libs)
 
 hmac256_SOURCES = hmac256.c
 hmac256_CFLAGS = -DSTANDALONE $(arch_gpg_error_cflags)
 hmac256_LDADD = $(arch_gpg_error_libs)
 
 if USE_RANDOM_DAEMON
 gcryptrnd_SOURCES = gcryptrnd.c
 gcryptrnd_CFLAGS = $(GPG_ERROR_CFLAGS) $(PTH_CFLAGS)
 gcryptrnd_LDADD = libgcrypt.la $(GPG_ERROR_LIBS) $(PTH_LIBS)
 
 getrandom_SOURCES = getrandom.c
 endif USE_RANDOM_DAEMON
 
 
 install-data-local: install-def-file