File PackageKit-gstreamer1.patch of Package PackageKit.2392

From 126c3c257f15029b84a352c05c548ba58bfdb04f Mon Sep 17 00:00:00 2001
From: Kalev Lember <kalevlember@gmail.com>
Date: Thu, 20 Mar 2014 19:45:04 +0100
Subject: [PATCH 1/2] gstreamer-plugin: Link with gstreamer 1.0

The plugin still supports both gstreamer 0.10 and 1.0, but is now
linked with and using the helper functions from gstreamer 1.0.

Signed-off-by: Richard Hughes <richard@hughsie.com>
---
 configure.ac | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/configure.ac b/configure.ac
index 4377321..0ed5a91 100644
--- a/configure.ac
+++ b/configure.ac
@@ -355,7 +355,7 @@ dnl ---------------------------------------------------------------------------
 AC_ARG_ENABLE(gstreamer_plugin, AS_HELP_STRING([--enable-gstreamer-plugin],[Build gstreamer plugin functionality]),
 	      enable_gstreamer_plugin=$enableval,enable_gstreamer_plugin=yes)
 if test x$enable_gstreamer_plugin = xyes; then
-	PKG_CHECK_MODULES(PK_GSTREAMER_PLUGIN, gstreamer-0.10 gstreamer-plugins-base-0.10 glib-2.0 gio-2.0,
+	PKG_CHECK_MODULES(PK_GSTREAMER_PLUGIN, gstreamer-1.0 gstreamer-plugins-base-1.0 glib-2.0 gio-2.0,
 	                  build_gstreamer_plugin=yes, build_gstreamer_plugin=no)
 else
 	build_gstreamer_plugin=no
-- 
1.8.4.5


From b612f7d4aaa2179960b40eb5a99eec6f25b5858e Mon Sep 17 00:00:00 2001
From: Dimitri John Ledkov <dimitri.ledkov@canonical.com>
Date: Wed, 2 Apr 2014 13:40:04 +0100
Subject: [PATCH 2/2] Link gstreamer plugin against 1.0 as well.

---
 configure.ac | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/configure.ac b/configure.ac
index 0ed5a91..7dc230b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -519,8 +519,8 @@ if test x$enable_aptcc = xyes; then
     AC_SUBST(APTCC_CFLAGS)
     AC_SUBST(APTCC_LIBS)
 
-	PKG_CHECK_MODULES(GSTREAMER, gstreamer-0.10 gstreamer-base-0.10 gstreamer-plugins-base-0.10,,
-					[AC_MSG_ERROR([Can't find the gstreamer libraries -- please install libgstreamermm-0.10-dev])])
+	PKG_CHECK_MODULES(GSTREAMER, gstreamer-1.0 gstreamer-base-1.0 gstreamer-plugins-base-1.0,,
+					[AC_MSG_ERROR([Can't find the gstreamer libraries -- please install libgstreamermm-1.0-dev])])
 	AC_SUBST(GSTREAMER_CFLAGS)
 	AC_SUBST(GSTREAMER_LIBS)
 
-- 
1.8.4.5
openSUSE Build Service is sponsored by