File at-spi2-core.spec of Package at-spi2-core.6361

#
# spec file for package at-spi2-core
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           at-spi2-core
Version:        2.20.2
Release:        0
Summary:        Assistive Technology Service Provider Interface - D-Bus based implementation
License:        GPL-2.0+
Group:          System/Libraries
Url:            http://www.gnome.org/
Source0:        http://download.gnome.org/sources/at-spi2-core/2.20/%{name}-%{version}.tar.xz
Source99:       baselibs.conf
# PATCH-FIX-UPSTREAM at-spi2-core-session-management.patch bsc#984109 mgorse@suse.com -- properly register at-spi-bus-launcher with gnome-session.
Patch0:         at-spi2-core-session-management.patch
# PATCH-FIX-UPSTREAM at-spi2-core-bgo791124-buffer-overflow.patch boo#1073027 bgo#791124 mgorse@suse.com -- Fix possible buffer overflow reading dbus address in at-spi-bus-launcher.
Patch1:         at-spi2-core-bgo791124-buffer-overflow.patch
BuildRequires:  intltool
BuildRequires:  update-desktop-files
BuildRequires:  pkgconfig(dbus-1) >= 1.0
BuildRequires:  pkgconfig(gio-2.0) >= 2.28
BuildRequires:  pkgconfig(glib-2.0) >= 2.36.0
BuildRequires:  pkgconfig(gobject-2.0) >= 2.0.0
BuildRequires:  pkgconfig(gobject-introspection-1.0)
BuildRequires:  pkgconfig(x11)
BuildRequires:  pkgconfig(xi)
BuildRequires:  pkgconfig(xtst)

# dbus-daemon is needed to have this work fine
Requires:       dbus-1
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
AT-SPI is a general interface for applications to make use of the
accessibility toolkit. This version is based on dbus.

This package contains the AT-SPI registry daemon. It provides a
mechanism for all assistive technologies to discover and interact
with applications running on the desktop.

%package -n libatspi0
Summary:        An Accessibility ToolKit -- Library
Group:          System/Libraries

%description -n libatspi0
AT-SPI is a general interface for applications to make use of the
accessibility toolkit. This version is based on dbus.

%package -n typelib-1_0-Atspi-2_0
Summary:        An Accessibility ToolKit -- Introspection bindings
Group:          System/Libraries

%description -n typelib-1_0-Atspi-2_0
AT-SPI is a general interface for applications to make use of the
accessibility toolkit. This version is based on dbus.

This package provides the GObject Introspection bindings for the
libatspi library.

%package devel
Summary:        Include Files and Libraries mandatory for Development
Group:          Development/Libraries/GNOME
Requires:       at-spi2-core = %{version}
Requires:       libatspi0 = %{version}
Requires:       typelib-1_0-Atspi-2_0 = %{version}

%description devel
This package contains all necessary include files and libraries needed
to develop applications that require these.

%lang_package
%prep
%setup -q
%patch0 -p1
%patch1 -p1

%build
%configure \
        --libexecdir=%{_libexecdir}/at-spi2 \
        --with-dbus-daemondir=/bin \
        --disable-xevie \
        --disable-static
make %{?_smp_mflags}

%install
%makeinstall
%suse_update_desktop_file at-spi-dbus-bus
%find_lang at-spi2-core
find %{buildroot}%{_libdir} -name '*.la' -type f -delete -print

%post -n libatspi0 -p /sbin/ldconfig

%postun -n libatspi0 -p /sbin/ldconfig

%files
%defattr(-,root,root)
%doc AUTHORS COPYING README
%{_libexecdir}/at-spi2/
%{_sysconfdir}/xdg/autostart/at-spi-dbus-bus.desktop
%{_userunitdir}/at-spi-dbus-bus.service
%dir %{_datadir}/dbus-1/accessibility-services/
%{_datadir}/dbus-1/accessibility-services/org.a11y.atspi.Registry.service
%{_datadir}/dbus-1/services/org.a11y.Bus.service
%dir %{_datadir}/defaults
%{_datadir}/defaults/at-spi2/

%files -n libatspi0
%defattr(-, root, root)
%{_libdir}/libatspi.so.0*

%files -n typelib-1_0-Atspi-2_0
%defattr(-, root, root)
%{_libdir}/girepository-1.0/Atspi-2.0.typelib

%files devel
%defattr(-, root, root)
%{_includedir}/at-spi-2.0/
%{_libdir}/libatspi.so
%{_libdir}/pkgconfig/atspi-2.pc
%{_datadir}/gir-1.0/*.gir
%dir %{_datadir}/gtk-doc
%dir %{_datadir}/gtk-doc/html
%doc %{_datadir}/gtk-doc/html/libatspi/

%files lang -f at-spi2-core.lang

%changelog