File cups-1.7.5-CVE-2020-3898.patch of Package cups.14660

--- cups/ppd.c.orig	2013-05-29 13:51:34.000000000 +0200
+++ cups/ppd.c	2020-04-06 13:58:01.232556350 +0200
@@ -1715,8 +1715,7 @@ _ppdOpen(
                      constraint->choice1, constraint->option2,
 		     constraint->choice2))
       {
-        case 0 : /* Error */
-	case 1 : /* Error */
+	default : /* Error */
 	    cg->ppd_status = PPD_BAD_UI_CONSTRAINTS;
 	    goto error;
 
--- ppdc/ppdc-source.cxx.orig	2013-02-04 20:27:13.000000000 +0100
+++ ppdc/ppdc-source.cxx	2020-04-06 13:59:46.904655487 +0200
@@ -1791,14 +1791,16 @@ ppdcSource::get_resolution(ppdcFile *fp)
 
   switch (sscanf(name, "%dx%d", &xdpi, &ydpi))
   {
-    case 0 :
-        _cupsLangPrintf(stderr,
-	                _("ppdc: Bad resolution name \"%s\" on line %d of "
-			  "%s."), name, fp->line, fp->filename);
-        break;
     case 1 :
         ydpi = xdpi;
 	break;
+    case 2 :
+        break;
+    default :
+        _cupsLangPrintf(stderr,
+                        _("ppdc: Bad resolution name \"%s\" on line %d of "
+                          "%s."), name, fp->line, fp->filename);
+        break;
   }
 
   // Create the necessary PS commands...
openSUSE Build Service is sponsored by