File disableSelfUpdate.patch of Package google-cloud-sdk.1615

--- lib/googlecloudsdk/core/config.json.orig
+++ lib/googlecloudsdk/core/config.json
@@ -1,6 +1,6 @@
 {
   "config_suffix": "", 
-  "disable_updater": false, 
+  "disable_updater": true, 
   "disable_usage_reporting": false, 
   "documentation_url": "https://developers.google.com/cloud/sdk/", 
   "release_channel": "rapid", 
@@ -9,4 +9,4 @@
   "snapshot_url": "https://dl.google.com/dl/cloudsdk/channels/rapid/components-2.json", 
   "user_agent": "Cloud SDK Command Line Tool", 
   "version": "0.9.87"
-}
\ No newline at end of file
+}
--- lib/googlecloudsdk/core/updater/local_state.py.orig
+++ lib/googlecloudsdk/core/updater/local_state.py
@@ -30,10 +30,11 @@ class InvalidSDKRootError(Error):
   """Error for when the root of the Cloud SDK is invalid or cannot be found."""
 
   def __init__(self):
-    super(InvalidSDKRootError, self).__init__(
-        'The update action could not be performed because the installation root'
-        ' of the Cloud SDK could not be located.  Please re-install the Cloud '
-        'SDK and try again.')
+      super(InvalidSDKRootError, self).__init__(
+          'The Cloud SDK is managed by a distribution package. If you wish to '
+          'use the SDK "components" functionality please un-install the '
+          'google-cloud-sdk package and install the source provided by Google: '
+          + config.INSTALLATION_CONFIG.documentation_url + '\n')
 
 
 class InvalidDownloadError(Error):