File libgit2-expected-error.patch of Package libgit2.9827

commit d3cb8f64cde3b84c3d1543f122f989aeb2f6a69e
Author: Carlos Martín Nieto <cmn@dwim.me>
Date:   Mon Jan 9 17:50:17 2017 +0000

    http: correct the expected error for RC4
    
    We must make sure that we're getting a certificate error from the
    library so we know that we're testing the right thing.

diff --git a/tests/online/badssl.c b/tests/online/badssl.c
index f3470f6..6dacc18 100644
--- a/tests/online/badssl.c
+++ b/tests/online/badssl.c
@@ -70,6 +70,8 @@ void test_online_badssl__old_cipher(void)
 	if (!g_has_ssl)
 		cl_skip();
 
-	cl_git_fail(git_clone(&g_repo, "https://rc4.badssl.com/fake.git", "./fake", NULL));
-	cl_git_fail(git_clone(&g_repo, "https://rc4.badssl.com/fake.git", "./fake", &opts));
+	cl_git_fail_with(GIT_ECERTIFICATE,
+			 git_clone(&g_repo, "https://rc4.badssl.com/fake.git", "./fake", NULL));
+	cl_git_fail_with(GIT_ECERTIFICATE,
+			 git_clone(&g_repo, "https://rc4.badssl.com/fake.git", "./fake", &opts));
 }
openSUSE Build Service is sponsored by