File 0001-Do-not-load-plugin-from-the-PWD.patch of Package libqt5-qtbase.16542

From 2e02b383e03c30f53ff613e431e8fe1d063d5502 Mon Sep 17 00:00:00 2001
From: Olivier Goffart <ogoffart@woboq.com>
Date: Fri, 8 Nov 2019 11:30:40 +0100
Subject: [PATCH] Do not load plugin from the $PWD

I see no reason why this would make sense to look for plugins in the current
directory. And when there are plugins there, it may actually be wrong

Change-Id: I5f5aa168021fedddafce90effde0d5762cd0c4c5
Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
(cherry picked from commit bf131e8d2181b3404f5293546ed390999f760404)
Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io>
(cherry picked from commit 52b739776daecf80a8276b49c9e4337e018d8e8b)
Reviewed-by: Olivier Goffart (Woboq GmbH) <ogoffart@woboq.com>
---
 src/corelib/plugin/qpluginloader.cpp | 1 -
 1 file changed, 1 deletion(-)

Index: qtbase-opensource-src-5.6.1/src/corelib/plugin/qpluginloader.cpp
===================================================================
--- qtbase-opensource-src-5.6.1.orig/src/corelib/plugin/qpluginloader.cpp
+++ qtbase-opensource-src-5.6.1/src/corelib/plugin/qpluginloader.cpp
@@ -298,7 +298,6 @@ static QString locatePlugin(const QStrin
         paths.append(fileName.left(slash)); // don't include the '/'
     } else {
         paths = QCoreApplication::libraryPaths();
-        paths.prepend(QStringLiteral(".")); // search in current dir first
     }
 
     foreach (const QString &path, paths) {
openSUSE Build Service is sponsored by