File ocki-3.1-fix-libica-link.patch of Package openCryptoki.2906

--- opencryptoki/configure.in
+++ opencryptoki/configure.in
@@ -328,7 +328,7 @@
 	old_cflags="$CFLAGS"
 	old_libs="$LIBS"
 	CFLAGS="$CFLAGS $LIBICA_CFLAGS"
-	LIBS="$LIBS $LIBICA_LIBS"
+	LIBS="$LIBS $LIBICA_LIBS -lrt -lcrypto -lpthread"
 	AC_CHECK_HEADER([ica_api.h], [], [
 		if test "x$with_libica" != "xcheck"; then
 			AC_MSG_ERROR([Build with Libica requested but Libica headers couldn't be found])
openSUSE Build Service is sponsored by