File gupnp-igd.changes of Package gupnp-igd

-------------------------------------------------------------------
Thu Feb  6 21:11:58 UTC 2014 - dimstar@opensuse.org

- Update to version 0.2.3:
  + Emit errors as boxed types.
  + Various build improvements.
  + Make tests less racy.
- Pass --enable-python to configure in order to ensure the python
  bindings to be built.

-------------------------------------------------------------------
Tue Dec  4 08:46:21 UTC 2012 - dimstar@opensuse.org

- Update to version 0.2.2:
  + Parallel build and linking fixes.
- Change python-gupnp-id Obsoletes to < %{version}, as we now have
  a new release. Fixes a rpmlint warning about self-obsoletion.

-------------------------------------------------------------------
Fri Dec 23 10:40:40 UTC 2011 - vuntz@opensuse.org

- Split typelib file into typelib-1_0-GUPnPIgd-1_0 subpackage.
- Add typelib-1_0-GUPnPIgd-1_0 Requires to libgupnp-igd-devel
  subpackage.
- Rename python-gupnp-id subpackage to python-gupnp-igd: there was
  a typo in the package name. Add appropriate Provides/Obsoletes.
- Remove libgupnp-devel Requires from libgupnp-igd-devel
  subpackage: it will automatically be added the pkgconfig() way.

-------------------------------------------------------------------
Tue Nov  8 10:10:50 UTC 2011 - dimstar@opensuse.org

- Update to version 0.2.1:
  + Restore the "main-context" property so that outsider can use
    the GUPnPIgdThread's GMainContext for timers, etc
- Changes from version 0.2.0:
  + Use the thread current GMainContext instead of passing it as a
    parameter
  + Make the GUPnPIgdThread object work with the new GUPnP 0.18
- Re-enabled parallel build.
- Rename libgupnp-igd-1_0-3 to libgupnp-igd-1_0-4, following
  upstreams soname change.

-------------------------------------------------------------------
Thu Jun 16 18:28:48 CEST 2011 - dimstar@opensuse.org

- Remove _service usage to follow current factory packaging style.

-------------------------------------------------------------------
Thu May  5 09:07:28 CEST 2011 - vuntz@opensuse.org

- Update to version 0.1.11:
  + Disable introspection correctly on --disable-introspection

-------------------------------------------------------------------
Fri Apr 29 14:49:09 UTC 2011 - dimstar@opensuse.org

- Update to version 0.1.10:
  + Port to gobject-introspection 0.10
- Changes from version 0.1.9:
  + Set thread default main context
- Changes from version 0.1.8:
  - Add GObject Introspection support
  - Return a valid GError if the other side returns an invalid IP
  - Make newer GNU Make and newer GCC happy
- Drop gupnp-igd-make382.patch and related autoreconf call: fixed
  upstream.
- Add gobject-introspection-devel BuildRequires for introspection
  support.
- Disable parallel build for now: it's broken.
- Use source services: download_url, recompress and set_version.

-------------------------------------------------------------------
Sat Sep 11 20:27:55 UTC 2010 - dimstar@opensuse.org

- Add gupnp-igd-make382.patch: Fix build with make 3.82
- Add autoreconf call in build section.
- Add gtk-doc BuildRequires.

-------------------------------------------------------------------
Mon Jun 21 12:48:54 CEST 2010 - dimstar@opensuse.org

- Update to version 0.1.7:
  + Fix race if g_main_loop_quit() is called just before
    g_main_loop_run()
  + override the main-context construct time property in the
    constructor
  + Fixed installation of python bindings

-------------------------------------------------------------------
Tue Jan  5 16:46:33 CET 2010 - vuntz@opensuse.org

- Update to version 0.1.6:
  + Add python bindings
- Add python-devel, python-gobject2-devel BuildRequires, and
  package python bindings in python-gupnp-id subpackage.

-------------------------------------------------------------------
Mon Dec  7 09:19:28 CET 2009 - vuntz@opensuse.org

- Update to version 0.1.5:
  + Use the new GUPnP Context Manager from GUPnP 0.13
- Rename libgupnp-igd-1_0-2 to libgupnp-igd-1_0-3 to follow soname
  bump.

-------------------------------------------------------------------
Mon Nov 30 20:13:14 CET 2009 - dimstar@opensuse.org

- Update to version 0.1.4:
  + Make it compatible with the 0.13 API
  + Bug fixes

-------------------------------------------------------------------
Sat Jun 13 23:43:02 CEST 2009 - vuntz@novell.com

- Initial package.