File open-lldp.changes of Package open-lldp

-------------------------------------------------------------------
Wed May 21 15:12:33 UTC 2014 - jsegitz@novell.com

- added necessary macros for systemd files

-------------------------------------------------------------------
Wed May 14 09:09:11 CEST 2014 - hare@suse.de

- Update to latest git version:
  * Include upstream version of VEPA migration issue (bnc#866282)
  * evb 22 test cases
  * vdp22 fixes
  * error message fixes
  * Fix interop issues with Juniper switches
- Fixup error messages in lldpad
  * Add 0001-lldpad-print-verbose-error-messages.patch
- Move to libnl3
  * Add 0002-Move-to-libnl3.patch

-------------------------------------------------------------------
Fri Mar 21 15:28:19 CET 2014 - hare@suse.de

- Fix VEPA migration issue (bnc#866282)
- Remove mkinitrd support
- Use bzip2 for open-lldp-git-update.patch
  * Add open-lldp-git-update.patch.bz2
  * Delete open-lldp-git-update.patch

-------------------------------------------------------------------
Tue Nov 19 12:52:45 CET 2013 - hare@suse.de

- Update to latest git version:
  * VPD22 support
  * Netlink fixes

-------------------------------------------------------------------
Thu Oct 10 15:14:39 UTC 2013 - tchvatal@suse.com

- Provide and Obsolete old devel packages to avoid collisons.
- More whitespace cleanup.

-------------------------------------------------------------------
Fri Sep 13 10:42:57 CEST 2013 - hare@suse.de

- Rename to open-lldp to be compliant with upstream
- Update to latest git version
  * Systemd integration
  * EVB fixes
- Update mkinitrd scriptlets
- Remove 'llpdad-makefile-fixup', merged with upstream
- Remove 'mkinitrd-stop.sh'
- Add open-lldp-git-update.patch to build properly

-------------------------------------------------------------------
Thu Aug  1 13:23:39 UTC 2013 - tchvatal@suse.com

- Bump to 0.9.46 new upstream url found from fedora pkg:
 * Add IEEE802.1Qbg EVB module support
 * add and improve test code evbest/nltest
 * 8021qaz fix to work with hardware that does not support CEE DCBX
 * support lldpad running on bonded interfaces
 * pretty print support for VDP
 * new -p option to display lldpad process identifier
 * generate shared library liblldp_clif for applications to use
 * Add vdptest program
 * various link event fixes
 * Support for multiple agent types Nearest non-TPMR, Nearest customer bridge,
   and Nearest Bridge (always supported).
 * New man pages for VDP, EVB, and MED have been added.
 * DCBX improvements to remap DCB attributes when the host has less traffic
   classes then the peer.
 * Support to parse 802.1AB Organizationally Specific TLVs, Cisco Specific TLVs
   and the LLINK attributes of the DCBX CEE TLVs.
 * Support to reconfigure and set the MSAP subtype.
 * Additional gcc warnings turned on and miscellaneous fixes.
 * New client interface (abstract sockets) to support initrd stage
 * IEEE 802.1Qaz support has been added
 * EVB support has been added
 * Add iSCSI TLV support
 * Numerous bug fixes and code cleanup
 * Reworked netlink event handling to be more robust and handle dropped nlmsgs.
 * DCBx puts netdevice into linkmode until dcbx negotiation complete
- Remove obsolete patches, applied upstream/done differently by upstream:
 * lldpad-0.9.32-compile-fixes
 * lldpad-0.9.32-fix-buffer-overflow
 * lldpad-0.9.32-fix-error-in-pgid-construction
 * lldpad-0.9.32-fix-lldptool-segfault
 * lldpad-0.9.32-fix-race-condition
- Rebase patch to apply on current version:
 * lldpad-makefile-fixup
- Use unit file instead of init file to move under systemd

-------------------------------------------------------------------
Tue Jul 23 19:02:58 CEST 2013 - ohering@suse.de

- Remove usage of absolute paths in mkinitrd scripts
- Add Requires(post/postun) to spec file

-------------------------------------------------------------------
Mon Feb 13 10:49:52 UTC 2012 - coolo@suse.com

- patch license to follow spdx.org standard

-------------------------------------------------------------------
Wed Nov 23 21:13:01 UTC 2011 - coolo@suse.com

- add libtool as buildrequire to avoid implicit dependency

-------------------------------------------------------------------
Tue Jul  6 10:53:00 CEST 2010 - hare@suse.de

- Port rpm from SLES11 SP1.

-------------------------------------------------------------------
Fri May  7 16:02:31 CEST 2010 - hare@suse.de

- Remove 'fix link flap' patch (bnc#603580)

-------------------------------------------------------------------
Mon Apr 26 13:53:10 CEST 2010 - hare@suse.de

- Patches from bnc#599107:
  * fix race condition by opening client socket earlier
  * fix error in construction of the Priority Group TLV
  * fix link flap
  * fix segfault when handling lldptool arguments
  * fix buffer overflow in lldp-med inventory string

-------------------------------------------------------------------
Fri Mar 26 11:50:46 CET 2010 - kukuk@suse.de

- Fix requires of -devel subpackage

-------------------------------------------------------------------
Wed Mar 24 16:00:04 CET 2010 - hare@suse.de

- Fixup mkinitrd setup script to always create /var/lib/lldpad

-------------------------------------------------------------------
Tue Mar 23 15:11:03 CET 2010 - hare@suse.de

- Obsolete dcbd by lldpad version 0.9.32 (bnc#590487)