File tpm-tools.spec of Package tpm-tools

#
# spec file for package tpm-tools
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


BuildRequires:  atk-devel
BuildRequires:  expat
BuildRequires:  fontconfig-devel
BuildRequires:  freetype2-devel
BuildRequires:  glib2-devel
BuildRequires:  gtk2-devel
BuildRequires:  openCryptoki-devel
BuildRequires:  openssl-devel
BuildRequires:  pango-devel
BuildRequires:  trousers-devel
BuildRequires:  xorg-x11-devel
BuildRequires:  xorg-x11-libs

Name:           tpm-tools
Url:            http://trousers.sourceforge.net/
Version:        1.3.8
Release:        0
Summary:        Trusted Platform Module (TPM) administration tools
License:        IPL-1.0
Group:          Productivity/Security
Source0:        http://downloads.sourceforge.net/project/trousers/tpm-tools/1.3.7/tpm-tools-%version.tar.gz
Source1:        %name-rpmlintrc
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
PreReq:         %install_info_prereq

%description
Trusted Computing is a set of specifications published by the Trusted
Computing Group (TCG). The Trusted Platform Module (TPM) is the
hardware component for Trusted Computing. The tpm-tools package
provides tools for enablement and configuration of the TPM and
associated interfaces. Also look inside the trousers package for more
software for TC.



Authors:
--------
    IBM Corp.

%prep
%setup -q

%build
# Disable unused-but-set warnings with gcc >= 4.6
%if 0%{?suse_version} >= 1200
export CFLAGS="%{optflags} -Wno-unused-but-set-variable"
%endif
%configure --disable-static
make

%check
make check

%post -p /sbin/ldconfig

%postun -p /sbin/ldconfig

%install
rm -rf $RPM_BUILD_ROOT
mkdir $RPM_BUILD_ROOT
make DESTDIR=$RPM_BUILD_ROOT install
rm $RPM_BUILD_ROOT/usr/%_lib/*.la
cp include/*.h $RPM_BUILD_ROOT/usr/include/tpm_tools

%files
%defattr(-,root,root)
%doc README LICENSE
%{_mandir}/man*/*
/usr/sbin/*
/usr/bin/*
/usr/%{_lib}/*.so
/usr/%{_lib}/*.so.*
/usr/include/tpm_tools

%changelog