File emacs-24.1-bnc628268.patch of Package emacs.7839

--- lisp/obsolete/spell.el
+++ lisp/obsolete/spell.el	2012-06-27 11:54:27.600009491 +0000
@@ -64,7 +64,7 @@ as its \"correct\" spelling; then the qu
   (with-no-warnings
     (spell-region (point-min) (point-max) "buffer")))
 ;;;###autoload
-(make-obsolete 'spell-buffer 'ispell-buffer "23.1")
+(define-obsolete-function-alias 'spell-buffer 'ispell-buffer "23.1")
 
 ;;;###autoload
 (defun spell-word ()
@@ -83,7 +83,7 @@ and `query-replace' the entire buffer to
     (with-no-warnings
       (spell-region beg end (buffer-substring beg end)))))
 ;;;###autoload
-(make-obsolete 'spell-word 'ispell-word "23.1")
+(define-obsolete-function-alias 'spell-word 'ispell-word "23.1")
 
 ;;;###autoload
 (defun spell-region (start end &optional description)
@@ -141,7 +141,7 @@ for example, \"word\"."
 	     (query-replace-regexp (concat "\\b" (regexp-quote word) "\\b")
 				   newword)))))))
 ;;;###autoload
-(make-obsolete 'spell-region 'ispell-region "23.1")
+(define-obsolete-function-alias 'spell-region 'ispell-region "23.1")
 
 ;;;###autoload
 (defun spell-string (string)