File python-python-gflags.changes of Package python-python-gflags

-------------------------------------------------------------------
Sat May  6 03:31:54 UTC 2017 - toddrme2178@gmail.com

- Don't provide python2-gflags, singlespec packages should use
  correct name.

-------------------------------------------------------------------
Wed Apr 26 16:20:48 UTC 2017 - alarrosa@suse.com

- Provide python-gflags in the python2 package

-------------------------------------------------------------------
Tue Apr 25 21:48:26 UTC 2017 - toddrme2178@gmail.com

- Fix URL.

-------------------------------------------------------------------
Tue Apr 25 20:13:24 UTC 2017 - toddrme2178@gmail.com

- Update to version 3.1.1
  * Added PEP8 style method/function aliases.
- Update to version 3.1.0
  * Python3 compatibility
  * Removed UnrecognizedFlag exception.
  * Replaced flags.DuplicateFlag with flags.DuplicateFlagError.
  * Moved the validators.Error class to exceptions.ValidationError.
  * Renamed IllegalFlagValue to IllegalFlagValueError.
  * Removed MutualExclusionValidator class, in favor of flags.MarkFlagsAsMutualExclusive.
  * Removed FlagValues.AddValidator method.
  * Removed _helpers.GetMainModule.
  * Use xml.dom.minidom to create XML strings, instead of manual crafting.
  * Declared PEP8-style names.
  * Added examples.
- Update to version 3.0.7
  * Removed the unused method ShortestUniquePrefixes.
  * Removed _GetCallingModule function alias.
- Update to version 3.0.6
  * Declared pypi package classifiers.
  * Added support for CLIF flag processing (not included in python-gflags repo
    yet).
- Update to version 3.0.5
  * Added a warning when FLAGS.SetDefault is used after flags were parsed.
  * Added new function: MarkFlagsAsRequired.
- Update to version 3.0.4
  * One more fix for setup.py - this time about third_party package.
- Update to version 3.0.3
  * Fixed setup.py.
  * --noflag if argument is given is no longer allowed.
  * Python3 compatibility: removed need for cgi import.
  * Disallowed unparsed flag usage after FLAGS.Reset()
- Update to version 3.0.2
  * Fix MANIFEST.in to include all relevant files.
- Update to version 3.0.1
  * Some changes for python3 compatibility.
  * Automatically generate ordering operations for Flag.
  * Add optional comma compatibility to whitespace-separated list flags.
  * A lot of potentially backwards incompatible changes since 2.0.
  * This version is NOT recommended to use in production. Some of the files and
    documentation has been lost during export; this will be fixed in next
    versions.
- Fix source URL
- Implement single-spec version

-------------------------------------------------------------------
Thu Feb 13 16:03:54 UTC 2014 - rschweikert@suse.com

- include in SLE 12 (FATE #316167)

-------------------------------------------------------------------
Thu Oct 24 11:12:43 UTC 2013 - speilicke@suse.com

- Require python-setuptools instead of distribute (upstreams merged)

-------------------------------------------------------------------
Fri Aug  9 15:35:26 UTC 2013 - rschweikert@suse.com

- update to version 2.0
  * Don't raise DuplicateFlag when re-importing a module (mmcdonald)
  * Changed the 'official' python-gflags email in setup.py/etc
  * Changed copyright text to reflect Google's relinquished ownership
  * Prepare gflags for python 3.x, keeping 2.4 compatibility (twouters)
  * If output is a tty, use terminal's width to wrap help-text (wiesmann)
  * PORTING: Fix ImportError for non-Unix platforms (kdeus)
  * PORTING: Run correctly when termios isn't available (shines)
  * Add unicode support to flags (csilvers)

-------------------------------------------------------------------
Thu Dec  8 13:53:17 UTC 2011 - idonmez@suse.com

- Update tarball to upstream version (no code changes) 

-------------------------------------------------------------------
Tue Nov 29 15:17:25 UTC 2011 - saschpe@suse.de

- Set license to SDPX style (BSD-3-Clause)

-------------------------------------------------------------------
Mon May 23 14:15:42 UTC 2011 - prusnak@opensuse.org

- updated to 1.6

-------------------------------------------------------------------
Tue Oct 26 00:00:00 UTC 2010 - silas@sewell.ch

- Fix non-executable-script error

-------------------------------------------------------------------
Wed Oct 13 00:00:00 UTC 2010 - silas@sewell.ch

- Initial package