File Fix-contrib-perlapi-to-build-with-the-fix-for-CVE-2019-6438-750cc23ed.patch of Package slurm.13628

From: Egbert Eich <eich@suse.com>
Date: Thu Jan 31 11:05:30 2019 +0100
Subject: Fix contrib/perlapi to build with the fix for CVE-2019-6438 (750cc23ed).
Patch-mainline: Not yet
Git-commit: a4a7f25dcb7d4387daa4367dd3c040f84b5e6f61
References: 

Signed-off-by: Egbert Eich <eich@suse.com>
---
 slurm-18.08.5/contribs/perlapi/libslurm/perl/slurm-perl.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/slurm-18.08.5/contribs/perlapi/libslurm/perl/slurm-perl.h b/slurm-18.08.5/contribs/perlapi/libslurm/perl/slurm-perl.h
index 58df275..d4adbfe 100644
--- a/contribs/perlapi/libslurm/perl/slurm-perl.h
+++ b/contribs/perlapi/libslurm/perl/slurm-perl.h
@@ -17,7 +17,7 @@
 #endif
 
 extern void slurm_xfree(void **, const char *, int, const char *);
-extern void *slurm_xmalloc(size_t, bool, const char *, int, const char *);
+extern void *slurm_xmalloc(uint64_t, bool, const char *, int, const char *);
 
 extern void slurm_api_clear_config(void);