File 0300-dracut_dont_use_dpkg_defaults_on_SUSE.patch of Package dracut.12460

From 9a3027a11ea5bac05c474a85da355e4e74793006 Mon Sep 17 00:00:00 2001
From: Hannes Reinecke <hare@suse.de>
Date: Wed, 4 May 2016 13:36:34 +0200
Subject: [PATCH] 50plymouth: don't use dpkg defaults on SUSE

Signed-off-by: Thomas Renninger <trenn@suse.com>
---
 modules.d/50plymouth/module-setup.sh | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)

diff --git a/modules.d/50plymouth/module-setup.sh b/modules.d/50plymouth/module-setup.sh
index 27dafca..d00f2f1 100755
--- a/modules.d/50plymouth/module-setup.sh
+++ b/modules.d/50plymouth/module-setup.sh
@@ -3,6 +3,8 @@
 # called by dracut
 check() {
     [[ "$mount_needs" ]] && return 1
+    # Don't include plymouth if plymouth-dracut package not installed
+    [ -x /usr/lib/plymouth/plymouth-populate-initrd ] || return 1
     require_binaries plymouthd plymouth plymouth-set-default-theme
 }
 
@@ -14,9 +16,10 @@ depends() {
 # called by dracut
 install() {
     PKGLIBDIR="/usr/lib/plymouth"
-    if type -P dpkg-architecture &>/dev/null; then
-        PKGLIBDIR="/usr/lib/$(dpkg-architecture -qDEB_HOST_MULTIARCH)/plymouth"
-    fi
+    # breaks if dpkg is installed on openSUSE
+    #if type -P dpkg-architecture &>/dev/null; then
+    #    PKGLIBDIR="/usr/lib/$(dpkg-architecture -qDEB_HOST_MULTIARCH)/plymouth"
+    #fi
     [ -x /usr/libexec/plymouth/plymouth-populate-initrd ] && PKGLIBDIR="/usr/libexec/plymouth"
 
     if grep -q nash ${PKGLIBDIR}/plymouth-populate-initrd \
-- 
2.6.6