File 0580-check_for_CONFIG_ACPI_TABLE_UPGRADE.patch of Package dracut.12460

From: Harald Hoyer <harald@redhat.com>
Subject: check for CONFIG_ACPI_TABLE_UPGRADE
References: bsc#1098448
Patch-Mainline: 046
Git-commit: 940169e8d8e500498a3f350b2b3f341ae6548492
Git-repo: https://github.com/dracutdevs/dracut.git

additionally as for CONFIG_ACPI_INITRD_TABLE_OVERRIDE
config parameter got renamed

Signed-off-by: Thomas Renninger <trenn@suse.com>

Index: dracut-044/dracut.sh
===================================================================
--- dracut-044.orig/dracut.sh	2018-06-20 17:43:56.664313292 +0200
+++ dracut-044/dracut.sh	2018-06-20 17:43:57.488359175 +0200
@@ -1046,8 +1046,8 @@ if [[ ! $print_cmdline ]]; then
     fi
 fi
 
-if [[ $acpi_override = yes ]] && ! check_kernel_config CONFIG_ACPI_INITRD_TABLE_OVERRIDE; then
-    dwarn "Disabling ACPI override, because kernel does not support it. CONFIG_ACPI_INITRD_TABLE_OVERRIDE!=y"
+if [[ $acpi_override = yes ]] && ! ( check_kernel_config CONFIG_ACPI_TABLE_UPGRADE ||  check_kernel_config CONFIG_ACPI_INITRD_TABLE_OVERRIDE ); then
+    dwarn "Disabling ACPI override, because kernel does not support it. CONFIG_ACPI_INITRD_TABLE_OVERRIDE!=y or CONFIG_ACPI_TABLE_UPGRADE!=y"
     unset acpi_override
 fi