File 0085-Assemble-Remove-obsolete-test-for-kernels-older-than.patch of Package mdadm.7989

From 0ef1043ce8dd3f36c7227aa4a260819c4c17c78d Mon Sep 17 00:00:00 2001
From: Jes Sorensen <jsorensen@fb.com>
Date: Wed, 12 Apr 2017 14:50:02 -0400
Subject: [PATCH] Assemble: Remove obsolete test for kernels older than 2.4
Git-commit: 0ef1043ce8dd3f36c7227aa4a260819c4c17c78d
Patch-mainline: mdadm-4.0+
References: bsc#1069165, bsc#1069167, bsc#1068030

We only support 2.6.15+ at this point

Signed-off-by: Jes Sorensen <jsorensen@fb.com>
Signed-off-by: Coly Li <colyli@suse.de>

---
 Assemble.c | 7 -------
 1 file changed, 7 deletions(-)

diff --git a/Assemble.c b/Assemble.c
index 22596b5..d6beb23 100644
--- a/Assemble.c
+++ b/Assemble.c
@@ -1487,13 +1487,6 @@ try_again:
 		return 1;
 	}
 	mddev = chosen_name;
-	if (get_linux_version() < 2004000) {
-		pr_err("Assemble requires Linux 2.4 or later, and\n"
-		       "     md driver version 0.90.0 or later.\n"
-		       "    Upgrade your kernel or try --build\n");
-		close(mdfd);
-		return 1;
-	}
 	if (pre_exist == NULL) {
 		if (mddev_busy(fd2devnm(mdfd))) {
 			pr_err("%s already active, cannot restart it!\n",
-- 
2.13.6
openSUSE Build Service is sponsored by