File texlive.changes of Package texlive.14236

-------------------------------------------------------------------
Thu Feb 20 06:21:10 UTC 2020 - Dr. Werner Fink <werner@suse.de>

- Switch also to user mktex in fmtutil script (boo#1159740, CVE-2020-8016)

-------------------------------------------------------------------
Wed Feb  5 06:56:24 UTC 2020 - Dr. Werner Fink <werner@suse.de>

- Check passwd not group file for user mktex 

-------------------------------------------------------------------
Fri Jan 31 12:32:25 UTC 2020 - Dr. Werner Fink <werner@suse.de>

- Introduce a user mktex as replacement for user nobody (boo#1159740, CVE-2020-8016)

-------------------------------------------------------------------
Wed Sep 26 11:54:24 UTC 2018 - Dr. Werner Fink <werner@suse.de>

- Add patch source-bsc1109673.dif to fix bsc#1109673 for CVE-2018-17407
  which is about buffer overflow in the handling of Type 1 fonts
  allowing arbitrary code execution

-------------------------------------------------------------------
Fri Apr 27 00:54:31 UTC 2018 - stefan.bruens@rwth-aachen.de

- Add patch source-dvipdfm-x.dif to fix XeTeX bug #151 (boo#1099563)

-------------------------------------------------------------------
Thu Apr 19 09:05:23 UTC 2018 - werner@suse.de

- Add patch source-lcdf-typetools.dif to help gcc8 (boo#1087075)

-------------------------------------------------------------------
Mon Apr  9 10:57:54 UTC 2018 - idonmez@suse.com

- Update source-poppler-0.59.1.dif to fix compilation with poppler
  0.63. Dict objects are now uncopyable, make a const reference
  instead.

-------------------------------------------------------------------
Thu Mar 15 08:54:09 UTC 2018 - werner@suse.de

- Add patch biber-perl-5.30.dif to avoid trouble with perl 5.30 and biber 

-------------------------------------------------------------------
Thu Mar 15 07:29:33 UTC 2018 - werner@suse.de

- Add missing dependencies for perl-biber (boo#1084900) 

-------------------------------------------------------------------
Wed Mar 14 18:57:04 UTC 2018 - crrodriguez@opensuse.org

- Remove xorg-x11-devel and Mesa-devel from buildrequires. 

-------------------------------------------------------------------
Tue Feb  6 15:14:53 UTC 2018 - meissner@suse.com

- drop freetype-devel buildrequires, we use freetype2 here.

-------------------------------------------------------------------
Mon Jan 29 14:41:24 UTC 2018 - sndirsch@suse.com

- removed unneeded 'BuildRequires: xorg-x11-util-devel' (bsc#1077489)

-------------------------------------------------------------------
Mon Jan 29 09:20:27 UTC 2018 - werner@suse.de

- For Leap 42.3 build without biber as the perl version does not fit 

-------------------------------------------------------------------
Mon Jan  8 12:55:08 UTC 2018 - werner@suse.de

- If zypper way of posttrans scripts are disabled do use the rpm
  %posttrans scriptlets (boo#1074128)

-------------------------------------------------------------------
Tue Dec 12 17:36:08 UTC 2017 - dimstar@opensuse.org

- Replace Mesa-libGL-devel and libOSMesa-devel BuildRequires with
  pkgconfig(gl) and pkgconfig(osmesa).
- Drop Mesa-libglapi-devel Buildequires: not needed by texlive for
  a while already.

-------------------------------------------------------------------
Thu Dec  7 11:20:45 UTC 2017 - dimstar@opensuse.org

- Escape the usage of %{VERSION} when calling out to rpm.
  RPM 4.14 has %{VERSION} defined as 'the main packages version'.

-------------------------------------------------------------------
Fri Nov 24 12:46:53 UTC 2017 - werner@suse.de

- Disable by a build conditions using zypper way of posttrans scripts
  as we already use %posttrans. Nevertheless correct naming scheme
  (boo#1069445)

-------------------------------------------------------------------
Tue Nov 14 16:41:11 UTC 2017 - werner@suse.de

- Sometimes user nobody has its own ~/.cache directory therefore
  split path at colon if found

-------------------------------------------------------------------
Wed Nov  8 08:22:20 UTC 2017 - werner@suse.de

- Add yet an other patch source-poppler-0.59.1.dif for poppler
  0.59 and up (boo#1060652)

-------------------------------------------------------------------
Fri Sep 22 14:26:49 UTC 2017 - dimstar@opensuse.org

- Add texlive-20170524-source-poppler059-1.patch: Adapt API usage
  to poppler 0.59.

-------------------------------------------------------------------
Mon Aug 14 11:36:01 UTC 2017 - werner@suse.de

- Add missing link from texdef to latexdef 

-------------------------------------------------------------------
Tue Aug  1 07:53:05 UTC 2017 - schwab@suse.de

- Define _GNU_SOURCE to request GNU extensions

-------------------------------------------------------------------
Thu Jun 29 12:13:34 UTC 2017 - werner@suse.de

- Avoid nasty warning about missing batchmode in ENVironment

-------------------------------------------------------------------
Wed Jun 28 07:56:00 UTC 2017 - nico.kruber@gmail.com

- add missing dependencies for perl-biber

-------------------------------------------------------------------
Wed Jun 14 12:59:21 UTC 2017 - werner@suse.de

- Let biber test suite not use 64bit longs on 32bit architectures 

-------------------------------------------------------------------
Wed Jun 14 08:10:24 UTC 2017 - werner@suse.de

- Modify patch source-luatex.dif, that is update luatex tree from
  version 2017033109 (r44589) to version 2017060901 (r44590) 

-------------------------------------------------------------------
Tue Jun 13 10:38:52 UTC 2017 - werner@suse.de

- Final TeXLive 2017 20170520

-------------------------------------------------------------------
Thu Jun  1 12:02:37 UTC 2017 - werner@suse.de

- Update to TeXLive 2017 20170520 pretest
- Update to biber 2.7
  * Add missing bblxml.pm
- Remove patch biber-perl-pre5.22.0.dif
- Add patch source-luatex.dif for new gcc-7.1
- Adopted patches biber-certs.dif, biblatex-encoding.dif,
  source-configure.dif, source-overflow.dif, source-warns.dif,
  and source-warns.dif

-------------------------------------------------------------------
Fri May 26 15:22:17 UTC 2017 - werner@suse.de

- Switch over from 20160523 source tree to 20160523b
  as it includes someminor bug fixes

-------------------------------------------------------------------
Fri May 26 11:07:07 UTC 2017 - werner@suse.de

- Use lua compatible configuration for TEXMFCNF in texmf.cnf

-------------------------------------------------------------------
Wed May  3 11:50:38 CEST 2017 - kukuk@suse.de

- Require user nobody needed by public in kpathsea-bin

-------------------------------------------------------------------
Wed Mar  8 12:02:02 UTC 2017 - werner@suse.de

- Modify patch kpathsea_cnf.dif to remove mpost from the allowed
  shell escaping commands (bsc#1028271, CVE-2016-10243)

-------------------------------------------------------------------
Tue Dec  6 16:57:18 UTC 2016 - werner@suse.de

- We want perl(Unicode::Collate) >= 1.14 for biblatex-biber 2.5 

-------------------------------------------------------------------
Tue Aug 23 14:14:49 UTC 2016 - bwiedemann@suse.com

- perl-biber requires perl(Class::Accessor) and perl(Data::Uniqid)
  at runtime (boo#995076)

-------------------------------------------------------------------
Fri Aug  5 12:30:50 UTC 2016 - werner@suse.de

- Avoid dangling symbolic link for texlive-dvipdfmx-bin (boo#992360)

-------------------------------------------------------------------
Tue Jul 19 11:48:39 UTC 2016 - werner@suse.de

- Update biblatex-biber to version 2.5 as otherwise the biber
  indexing engine is not usable due version mismatch (boo#989486) 

-------------------------------------------------------------------
Fri Jul 15 10:02:40 UTC 2016 - werner@suse.de

- Avoid missing dependencies due upstream package splits

-------------------------------------------------------------------
Fri Jul  8 12:06:53 UTC 2016 - werner@suse.de

- Use the latest revision of upmendex/fwrite.c (r.41498) 
  to get stack smashing fixed as well as a working upmendex

-------------------------------------------------------------------
Tue Jun 14 13:03:21 UTC 2016 - werner@suse.de

- Avoid stack smashing deteted on i586 in upmendex/fwrite.c
- Add patch biber-perl-pre5.22.0.dif
  as with perl 5.18 and below fastsort does not work

-------------------------------------------------------------------
Tue Jun  7 11:35:15 UTC 2016 - werner@suse.de

- Update to TeXLive 2016
  * Remove the now included patches
    biber-perl-5.22.dif
    biber-perl-unicode-normalize.dif
    biber-skip-bibtex-forms.dif
    source-xdvik-events.dif
  * Adopted the following patches
    biber-certs.dif
    source-configure.dif
    source-dvipng.dif
    source-dviutils.dif
    source-missed-scripts.dif
    source-warns.dif
    source.dif

-------------------------------------------------------------------
Wed Apr 13 13:59:41 UTC 2016 - werner@suse.de

- Use some more system libraries
- Avoid to prerequire own packages at build time

-------------------------------------------------------------------
Wed Apr 13 09:21:49 UTC 2016 - schwab@suse.de

- Use system libmpfr

-------------------------------------------------------------------
Tue Apr 12 16:04:19 UTC 2016 - werner@suse.de

- Work around broken perl_gen_filelist rpm macro

-------------------------------------------------------------------
Wed Mar 30 14:32:20 UTC 2016 - werner@suse.de

- Change Recommends for binary packages on their main packages
  to Requires(pre) even if we get a dependency loop as otherwise
  some developers to not get it right.
- Add some basic Recommends for binary packages to have an
  basic environment around.

-------------------------------------------------------------------
Mon Mar 21 13:57:38 UTC 2016 - werner@suse.de

- Really require the library packages with texive-bin-devel 

-------------------------------------------------------------------
Sat Mar  5 14:17:59 UTC 2016 - werner@suse.de

- Fix version template to get version of libtexlua52 right 

-------------------------------------------------------------------
Fri Mar  4 09:47:55 UTC 2016 - werner@suse.de

-  Split off shared libraries and the development headers for
   synctex, lua52, and luajit as separate packages.

-------------------------------------------------------------------
Tue Feb  9 10:22:57 UTC 2016 - kruber@zib.de

- new perl-biber also requires perl module Text::Roman

-------------------------------------------------------------------
Tue Feb  9 08:12:05 UTC 2016 - werner@suse.de

- Let texlive-ps2pk Obsoletes texlive-ps2pkm (boo#965472)

-------------------------------------------------------------------
Mon Feb  8 10:36:43 UTC 2016 - werner@suse.de

- Also enforce fmtutil.pl to use FHS as then it will find mktexlsr.pl
  boo#965151 

-------------------------------------------------------------------
Thu Feb  4 14:58:39 UTC 2016 - werner@suse.de

- Fix bug boo#965151 that is wrong perl syntax 

-------------------------------------------------------------------
Wed Feb  3 13:15:30 UTC 2016 - werner@suse.de

- Make it build even on Leap with old perl 5.18.2 

-------------------------------------------------------------------
Tue Feb  2 17:41:37 UTC 2016 - werner@suse.de

- On older systems the linpoppler is somewhat to old

-------------------------------------------------------------------
Tue Feb  2 08:11:37 UTC 2016 - werner@suse.de

- Be aware that LuaJIT does not build on all architectures

-------------------------------------------------------------------
Thu Jan 28 10:52:36 UTC 2016 - werner@suse.de

- Update to TeXLive 2015 (timestamp 20150521 revision 26946)
  * Remove the now included patches
    biber-decode.diff
    biber-noreadonly.diff
    biblatex-biber-1.8.tar.xz
    source-asymptote-gs9.15.dif
  * Readd patch biber-certs.dif
    as we do not ship perls Motilla:CA
  * Add upstream patches
    biber-perl-unicode-normalize.dif
    biber-skip-bibtex-forms.dif
  * Add patch source-missed-scripts.dif to work around missed
    symbolic linked scripts
  * Adopted the following patches
    biber-perl-5.18.2.dif becomes biber-perl-5.22.dif
    biblatex-encoding.dif
    source-configure.dif
    source-dvipng.dif
    source-dviutils.dif
    source-lacheck.dif
    source-overflow.dif
    source-warns.dif
    source-x11r7.dif
    source.dif

-------------------------------------------------------------------
Tue Jul 14 14:25:04 UTC 2015 - werner@suse.de

- Add patch biber-perl-5.22.dif to make regular expressions work
  even with perl 5.22 (boo#938018, patch by Friedrich Haubensak)

-------------------------------------------------------------------
Fri Apr 17 13:40:24 UTC 2015 - werner@suse.de

- Port the patch set 'remove or clarify "nosell" material' from
  upstream to TeXlive source tar ball of 2014 (bsc#926106)

-------------------------------------------------------------------
Wed Apr  1 08:58:37 UTC 2015 - werner@suse.de

- Add patch source-asymptote-gs9.15.dif to switch from espwrite
  device to eos2write device of ghostscript (boo#912398)

-------------------------------------------------------------------
Tue Mar 31 15:49:35 UTC 2015 - werner@suse.de

- Luajittex does only compile on Intel, PPC, and ARM_LE (EABI)

-------------------------------------------------------------------
Thu Mar 26 14:05:48 UTC 2015 - werner@suse.de

- Update to TeXLive 2014 (timestamp 20140525 revision 34252)
  * Support DVIPDFMx
  * [fix] avoid luatex crash under math_mode 'decimal'
  * luaotfload: Fix incorrect handling of font file formats luaotfload)
  * Sync with Context beta as of 2014-04-05
  * pdfTeX: sync with Knuth TeX 3.14159265, e-TeX 2.6
  * Many more ...
- Update biblatex-biber to 1.8
- Add upstrema patch
   source-xdvik-events.dif
  to make Xaw3d work
- Remove the now included patches
    biber-av.patch
    biber-certs.dif
    biber-dev.patch
    source-asymptote.dif
    source-bnc856363.dif
    source-dvipdfmx.dif
    source-poppler-0.26.patch
    source-psutils-flip.dif
- Adapted the following patches
    biber-decode.diff
    biber-noreadonly.diff
    biblatex-encoding.dif
    source-64.dif
    source-arraysubs.dif
    source-configure.dif
    source-dviutils.dif
    source-lacheck.dif
    source-poppler.dif
    source-psutils.dif
    source-texdoc.dif
    source-warns.dif
    source-x11r7.dif
    source-xdvizilla.dif
    source.dif

-------------------------------------------------------------------
Sun Mar 15 17:25:38 UTC 2015 - jengelh@inai.de

- Remove redundant ldconfig requires

-------------------------------------------------------------------
Sat Dec 13 22:03:00 UTC 2014 - Led <ledest@gmail.com>

- fix shebang of xdvi script: option '-a' of 'exec' command may be
  unsupported in some POSIX-complete shells
- update patches:
  * source.dif

-------------------------------------------------------------------
Tue Nov 11 15:11:39 UTC 2014 - toddrme2178@gmail.com

- Make pdfjam-bin subpackage obsolete the older pdfjam package.
  These two packages provide the same binaries.

-------------------------------------------------------------------
Tue Jul 15 18:24:30 CEST 2014 - mls@suse.de

- Add biber-decode.diff: Fix build with perl-5.20.0, where
  Encode::decode_utf8 no longer short-circuits if the input
  is already utf8.

-------------------------------------------------------------------
Tue May 20 09:23:14 UTC 2014 - schwab@suse.de

- Make sure that texconfig/update is run only once per transaction

-------------------------------------------------------------------
Fri May  2 08:40:22 UTC 2014 - werner@suse.de

- Correct patch number scheme of latest change

-------------------------------------------------------------------
Wed Apr 30 20:05:29 UTC 2014 - dimstar@opensuse.org

- Add source-poppler-0.26.patch: Fix build with poppler 0.26:
  with poppler commit e04cab, there was an API break. Apply patch
  onlt when building against poppler 0.26 or newer.

-------------------------------------------------------------------
Fri Jan 31 20:28:55 UTC 2014 - rschweikert@suse.com

- The Perl Readonly module changes semantics with version 1.04 such that
  Readonly variables are read only across contexts. Therefore using
  a read only variable as an XML namespace context name triggers an
  error when the context gets unregistered and an attempt is made to
  reset the variable.
  ~ add patch biber-noreadonly.diff to address the issue

-------------------------------------------------------------------
Sat Jan 25 09:25:19 UTC 2014 - coolo@suse.com

- remove buildrequire kernel-devel, there are no kmps in here

-------------------------------------------------------------------
Mon Jan 13 11:15:56 UTC 2014 - werner@suse.de

- Add upstream patch source-dvipdfmx.dif
  to avoid trouble with big endian
- Extend patch source-configure.dif to change package name for
  dvipdfmx (bnc#858412)

-------------------------------------------------------------------
Fri Dec 20 08:40:42 UTC 2013 - werner@suse.de

- Add patch
  source-bnc856363.dif
  from upstream CVS to fix bnc#856363 - xdvi -sourceposition exits
  with Fatal error: currinf.set_char_p...
  compare with https://sourceforge.net/p/xdvi/bugs/388/

-------------------------------------------------------------------
Wed Nov 13 13:06:23 UTC 2013 - werner@suse.de

- Make biber a simple perl script that is provide a new package
  perl-biber for the library files

-------------------------------------------------------------------
Mon Oct 28 14:12:33 UTC 2013 - werner@suse.de

- Tar is now squeamishly with create and same order option 

-------------------------------------------------------------------
Thu Sep 26 10:37:10 UTC 2013 - werner@suse.de

- Correct SELFAUTODIR and SELFAUTOPARENT 

-------------------------------------------------------------------
Wed Sep 25 08:59:50 UTC 2013 - werner@suse.de

- Be aware that texlive scripts are now in the packages them self 

-------------------------------------------------------------------
Mon Sep  9 06:57:43 UTC 2013 - werner@suse.de

- Do not install duplicate files as already removed from file list 

-------------------------------------------------------------------
Thu Sep  5 08:20:44 UTC 2013 - werner@suse.de

- Remove `config(ca-certificates)' requirement and recommend
  ca-certificates as well as ca-certificates-mozilla
- Remove duplicate files from file list of musixtex

-------------------------------------------------------------------
Mon Sep  2 09:31:02 UTC 2013 - werner@suse.de

- Add patch biber-av.patch form upstream to avoid Data::Diver perl
  module and use autovivification

-------------------------------------------------------------------
Tue Aug 20 09:44:09 UTC 2013 - mvyskocil@suse.com

- Drop t1lib from dependencies as xdvi uses FreeType
- add few %dir to filelist to fix a build

-------------------------------------------------------------------
Thu Aug  8 14:43:07 UTC 2013 - werner@suse.de

- Do not override TEXMFLOCAL with TEXMFMAIN as this is now TEXMFDIST

-------------------------------------------------------------------
Thu Aug  8 09:46:54 UTC 2013 - werner@suse.de

- Add patch biblatex-encoding.dif - explicite load PerlIO::encoding
  for output files, seems to be required for our perl (bnc#833815)

-------------------------------------------------------------------
Wed Aug  7 09:57:30 UTC 2013 - werner@suse.de

- Repair several wrong paths cause by the move of TEXMFMAIN that is 
  + the location of TLUtils.pm used by updmap 
  + the location of xasy.py
- Help aysmptote configure script to detect libOSMesa with the
  implicite dependcy to libglapi which now provides the offscreen
  feature of aysmptote

-------------------------------------------------------------------
Tue Aug  6 09:24:21 UTC 2013 - werner@suse.de

- Reset development version string with current version

-------------------------------------------------------------------
Mon Aug  5 10:24:25 UTC 2013 - werner@suse.de

- Make sure that TEXMFMAIN is /usr/share/texmf now 

-------------------------------------------------------------------
Thu Aug  1 07:58:46 UTC 2013 - werner@suse.de

- Be aware that for older oepnSUSE there is no libOSMesa-devel
  but a Mesa-devel for libOSMesa.so 

-------------------------------------------------------------------
Tue Jul 30 16:14:46 UTC 2013 - werner@suse.de

- Update to TeXLive 2013 (timestamp 20130620)
  + Distribution layout: the top-level texmf/ directory has been
    merged into texmf-dist/, for simplicity. Both the TEXMFMAIN
    and TEXMFDIST Kpathsea variables now point to texmf-dist.
  + Many small language collections have been merged together,
    to simplify installation.
  + MetaPost: native support for PNG output and floating-point
    (IEEE double) has been added.
  + LuaTEX: updated to Lua 5.2, and includes a new library
    (pdfscanner) to process external PDF page content, among
    much else (see its web pages).
  + XeTEX (also see its web pages for more):
    The HarfBuzz library now used for font layout instead of ICU.
    Graphite2 and HarfBuzz are used instead of SilGraphite for Graphite layout.
    On Macs, Core Text is used instead of the (deprecated) ATSUI.
    Prefer TrueType/OpenType fonts to Type1 when the names are the same.
    Fix occasional mismatch in font finding between XeTEX and xdvipdfmx.
    Support OpenType math cut-ins.
  + xdvi: now uses FreeType instead of t1lib for rendering.
  + microtype.sty: some support for XeTEX (protrusion) and LuaTEX
    (protrusion, font expansion, tracking), among other enhancements. 
- Update biblatex-biber to 1.7
- Udpate biblatex of TeXLive 2013 to 2.7a
- Remove source-binary-open.dif as now upstream
- Remove source-xdvi-xkbbell.dif as now upstream
- Add biber-certs.dif to use system certificates instead of Mozilla CA
- Add biber-dev.patch to make  biblatex-biber work with perl 5.18.0
- Modify source-64.dif, source-asymptote.dif, source-poppler.dif,
  source-texdoc.dif, source-warns.dif, and source.dif to make it
  compile.

-------------------------------------------------------------------
Wed Jul 17 08:54:11 UTC 2013 - werner@suse.de

- Use PreReq for own packages instead of Requires(prereq)

-------------------------------------------------------------------
Tue Jul 16 12:36:45 UTC 2013 - werner@suse.de

- Let texlive-biber require perl(LWP::UserAgent) to be able to
  read system based certificates
- New rpm had removed "prereq" flag from installation script bits
  that is that `Requires(prereq)' is not valid anymore :(((

-------------------------------------------------------------------
Thu May 16 09:35:39 CEST 2013 - mhrusecky@suse.cz

- backward compatibility Provides: texlive-bin-dvilj (SR#175836)

-------------------------------------------------------------------
Tue May  7 08:45:34 UTC 2013 - werner@suse.de

- As lcdf-typetools does not support kpathsea nor search below
  texmf tree build the texlive-lcdftypetools(-bin) packages again
  and let them conflict with the lcdf-typetools package.

-------------------------------------------------------------------
Fri May  3 09:53:07 UTC 2013 - werner@suse.de

- Let texlive-pdfjam require texlive-pdfpages (bnc#814804)
- Let texlive-pdftools require texlive-pst-pdf (bnc#812286)
- Correct license boolean for biber packages
- Let texlive-tex4ht-bin conflict with ht due path /usr/bin/ht
- Let texlive-lcdftypetools(-bin) packages depend on lcdf-typetools
  package or conflict.

-------------------------------------------------------------------
Wed Mar 27 13:23:46 UTC 2013 - werner@suse.de

- Change Obsoletes from < 2012+subversion to <= 2011 (bnc#811162)
- Let mathdesign require tex(texnansi.enc) (bnc#808731)
- Let biber-bin require perl(Text::BibTeX) (bnc#811258)
- Do not require xfs as we do not use xfs at all, otherwise we
  have to add some more lua code in the %post scriptlet.

-------------------------------------------------------------------
Thu Feb 21 14:02:39 UTC 2013 - werner@suse.de

- Add patch source-xdvi-xkbbell.dif from upstream to add aupport for
  XkbBell, fix bugs in handling source specials on 64bit systems,
  and allow mksedscript to handle macro values containing spaces.

-------------------------------------------------------------------
Tue Feb  5 09:08:31 UTC 2013 - werner@suse.de

- Work around missing support of %posttrans scriptlets in libzypp
  due missing rpm option for not to execute those scriptlets (bnc#773575)

-------------------------------------------------------------------
Fri Dec 21 09:00:17 UTC 2012 - werner@suse.de

- remove conflicting libicu buildrequires as required by the arm
  people (was SR#146133)

-------------------------------------------------------------------
Wed Jun 27 09:00:58 UTC 2012 - werner@suse.de

- Re-add the rungs script to dvipdfmx-bin

-------------------------------------------------------------------
Tue Jun 26 11:25:50 UTC 2012 - werner@suse.de

- Do not open pipes in binary mode on POSIX systems 

-------------------------------------------------------------------
Tue Jun 26 10:16:05 UTC 2012 - werner@suse.de

- Avoid dependency loop between tex and texlive main package 
- Set a recommendation to scheme-medium

-------------------------------------------------------------------
Mon Jun 25 12:07:44 UTC 2012 - werner@suse.de

- Do not remove /var/run/texlive 

-------------------------------------------------------------------
Fri Jun 22 13:11:08 UTC 2012 - werner@suse.de

- The new updmap requires the perl mudules TLConfig.pm and TLUtils.pm 

-------------------------------------------------------------------
Wed Jun 20 12:51:57 UTC 2012 - werner@suse.de

- Make real package split between binary texlive and noarch
  texlive-filesystem and its collection/scheme packages

-------------------------------------------------------------------
Wed Jun 20 10:38:21 UTC 2012 - werner@suse.de

- Avoid to be fooled by wrong ownerships during fmtutil that is
  allow user nobody and group mktex to access the temporary
  fmtutil directory if the initial user is root

-------------------------------------------------------------------
Tue Jun 19 15:22:47 UTC 2012 - werner@suse.de

- Move old SuSEconfig md5 backup files to new location 

-------------------------------------------------------------------
Tue Jun 19 10:53:41 UTC 2012 - werner@suse.de

- Add missed /var/lib/texmf/web2c/ tree to file system

-------------------------------------------------------------------
Mon Jun 18 07:23:56 UTC 2012 - werner@suse.de

- Simplify dependency chain(s)

-------------------------------------------------------------------
Thu Jun 14 11:55:02 UTC 2012 - werner@suse.de

- Make RPMlint happy again 

-------------------------------------------------------------------
Thu Jun 14 10:59:06 UTC 2012 - werner@suse.de

- Correct version numbers of kpathsea and ptexenc automatically

-------------------------------------------------------------------
Wed Jun 13 08:16:02 UTC 2012 - werner@suse.de

- Readd well known paclages like texlive-devel, texlive-bin-devel,
  and texlive-tools.  Also cause texlive-latex to install its
  binary packages.

-------------------------------------------------------------------
Tue Jun 12 17:56:31 UTC 2012 - werner@suse.de

- Update to frozen/final 2012 (timestamp 20120611)

-------------------------------------------------------------------
Tue Jun 12 12:18:05 UTC 2012 - werner@suse.de

- Do not drop the tar scheme and collection tar balls for reference
- Split off texlive-filesystem, texlive-scheme, and texlive-collection
  build into a separate spec file
- Make version comparision work as we use upstream version and
  release numbers

-------------------------------------------------------------------
Sat Jun  9 05:44:25 UTC 2012 - coolo@suse.com

- relax the version requirements

-------------------------------------------------------------------
Fri Jun  8 15:04:36 UTC 2012 - coolo@suse.com

- split out collections and filesystem

-------------------------------------------------------------------
Mon Jun  4 07:48:37 UTC 2012 - werner@suse.de

- Avoid source url for all tar balls as our checkin script can not
  handle snapshots nor is knowing about the infrastructure of the
  upstream TeXLive server

-------------------------------------------------------------------
Fri Jun  1 08:06:51 UTC 2012 - werner@suse.de

- Change also version/release scheme of the sub binary subpackages 

-------------------------------------------------------------------
Thu May 31 11:34:39 UTC 2012 - werner@suse.de

- Change version/release scheme 

-------------------------------------------------------------------
Tue May 22 08:12:13 UTC 2012 - werner@suse.de

- Install manaul page of biber as this is also build
- Require the used perl version for biber 

-------------------------------------------------------------------
Mon May 21 11:22:16 UTC 2012 - werner@suse.de

- Try to support BibteX-Biber perl dumped binary required to
  provide BibteX-Biber also for PPC nad PPC64 

-------------------------------------------------------------------
Fri May 18 16:17:36 UTC 2012 - werner@suse.de

- Use texlive.texlive instead of texlive.texmf for permission file

-------------------------------------------------------------------
Fri May 18 14:25:00 UTC 2012 - werner@suse.de

- Be aware new poppler library, there is no getSize() but only
  getNumObjects() 

-------------------------------------------------------------------
Mon May 14 14:14:13 UTC 2012 - werner@suse.de

- Cron: remove older sources as well as crap 

-------------------------------------------------------------------
Mon May 14 11:59:48 UTC 2012 - werner@suse.de

- Avoid warning messages from mktexlsr due empty ls-R
- Handle case where public program is not setgid public
- Make spec file more flexible and use a rpm macro for a public
  group which can be named to e.g. public

-------------------------------------------------------------------
Mon May 14 11:34:42 UTC 2012 - werner@suse.de

- If MT_FEATURES includes varfonts and system default is not
  writable choose $HOME/.cache/texmf/fonts 

-------------------------------------------------------------------
Tue Dec 20 13:24:26 UTC 2011 - werner@suse.de

- First initial main spec file using the original TeX Live packaging
  scheme and layout
openSUSE Build Service is sponsored by