File nvidia-uvm-gfxG03.changes of Package nvidia-gfxG03

-------------------------------------------------------------------
Mon Jan  6 12:51:25 UTC 2020 - Stefan Dirsch <sndirsch@suse.com>

- added "azure" kernel flavor 

-------------------------------------------------------------------
Sun Jan  5 11:57:58 UTC 2020 - Stefan Dirsch <sndirsch@suse.com>

- update to version 340.108
  * Updated the nvidia-drm kernel module for compatibility with the removal
    of the DRIVER_PRIME flag in recent Linux kernel versions.
  * Updated nvidia-bug-report.sh to search the systemd journal for
    gdm-x-session logs.
  * Fixed a bug that could prevent nvidia-xconfig from disabling the X
    Composite extension on version 1.20 of the X.org X server.
  * Added support to nvidia-installer for systems which provide ncurses
    libraries supporting the ncurses widechar ABI only.
  * Updated nvidia-installer to avoid problems with commands whose proper
    functionality may be dependent on system localization (e.g. via the
    LANG environment variable.) For example, some kernel configurations
    may produce unusable kernel modules if LANG is set to a language
    other than English.
  * Updated nvidia-installer for better compatibility with ncurses when
    libncurses.so.6 exposes the ncurses reentrant ABI, such as on openSUSE
    Leap 15 and SUSE Linux Enterprise 15.
  * Fixed a build failure, "too many arguments to function 'get_user_pages'",
    when building the NVIDIA kernel module for Linux kernel v4.4.168.
  * Fixed a build failure, "implicit declaration of function do_gettimeofday",
    when building the NVIDIA kernel module for Linux kernel 5.0 release
    candidates.
- supersedes kernel-5.3.patch
- supersedes build fix for removed DRIVER_PRIME in kernel >= 5.4

-------------------------------------------------------------------
Fri Oct 11 12:09:00 UTC 2019 - Stefan Dirsch <sndirsch@suse.com>

- only apply kernel-5.3.patch on kernels >= 5.3; fixes build again
  on sle11 ...

-------------------------------------------------------------------
Mon Aug 19 10:49:32 UTC 2019 - Stefan Dirsch <sndirsch@suse.com>

- moved exit from %post snippet file to specfile after running
  weak-modules2 (boo#1145316)

-------------------------------------------------------------------
Mon Jul  8 14:15:14 UTC 2019 - Stefan Dirsch <sndirsch@suse.com>

- kmp-post.sh/kmp-trigger.sh
  * exit with error code 1 from %post/%trigger, if kernel module 
    build/install fails (boo#1131028)

-------------------------------------------------------------------
Fri Oct 12 13:34:00 UTC 2018 - sndirsch@suse.com

- let nvidia-glG03 %post-require xorg-x11-server, since on       
  Optimus we want to switch back to X.Org's libglx.so (bsc#1111471)

-------------------------------------------------------------------
Fri Oct 12 09:49:36 UTC 2018 - sndirsch@suse.com

- let nvidia-glG03 recommend the following packages:
  * Mesa-libGL1
  * Mesa-libEGL1
  * Mesa-libGLESv1_CM1
  * Mesa-libGLESv2-2
  This is needed for Optimus systems once NVIDIA's GL libs get disabled
  (our default); these packages won't get installed when adding NVIDIA's
  repository before the installation, which e.g. happens on SLED
  (bsc#1111471)

-------------------------------------------------------------------
Thu Jun  7 09:59:37 UTC 2018 - sndirsch@suse.com

- update to version 340.106
  * Updated nvidia-installer in the 340.xx legacy driver series to default
    to installing the driver without the NVIDIA Unified Memory kernel
    module if this module fails to build at installation time. The 340.xx
    legacy Unified Memory kernel module is incompatible with recent Linux
    kernels, and the GPU hardware generations that the 340.xx legacy driver
    series is intended to support do not support Unified Memory.
  * Added support for X.Org xserver ABI 24 (xorg-server 1.20).
  * Improved nvidia-bug-report.sh to check for kern.log which is the default
    kernel log-file location for many Debian-based Linux distributions.
  * Fixed a bug which could cause X servers that export a Video Driver
    ABI earlier than 0.8 to crash when running X11 applications which
    call XRenderAddTraps().

-------------------------------------------------------------------
Thu May 17 19:00:33 UTC 2018 - sndirsch@suse.com

- workaround build failure of kernelrelease target on sle12-sp4
  (boo#1093333)

-------------------------------------------------------------------
Thu Feb  8 23:25:45 UTC 2018 - sndirsch@suse.com

- update to version 340.106
-  supersedes kernel-4.14.patch, kernel-4.15.patch

-------------------------------------------------------------------
Sat Sep 30 12:55:22 UTC 2017 - sndirsch@suse.com

- update to version 340.104
  * Improved compatibility with recent Linux kernels.
  * Updated nvidia-installer to label kernel modules with SELinux
    file type 'modules_object_t'. Some system SELinux policies only
    permit loading of kernel modules with this SELinux file type.
  * Removed support for checking for and downloading updated driver
    packages and precompiled kernel interfaces from nvidia-installer.
    This functionality was limited to unencrypted ftp and http, and
    was implemented using code that is no longer actively maintained.
- obsoletes nvidia-340-4.12.patch, added kernel-4.11.patch for remaining
  issues in uvm module

-------------------------------------------------------------------
Thu Aug 31 12:27:47 UTC 2017 - sndirsch@suse.com

- nvidia-340-4.12.patch
  * new patch for Kernel 4.12
  * obsoletes nvidia-340-4.10.patch
- added %preinstall section to KMP for real, so existing manual
  NVIDIA driver installation gets uninstalled before KMP is being
  installed

-------------------------------------------------------------------
Mon Jul 24 14:37:16 UTC 2017 - sndirsch@suse.com

- add patch nvidia-340-4.10.patch to fix build with kernel 4.10
  and above (taken from nvidia forum) 

-------------------------------------------------------------------
Mon Apr 24 17:24:18 UTC 2017 - toddrme2178@gmail.com

- Various spec file and rpmlint cleanups:
  * Improve descriptions
  * Add URL
  * Remove spurious obsoletes (higher versions don't necessarily
    replace lower ones due to dropped graphics card support).
  * Add %config tags
  * Update year
  * Use versioning provides to avoid self-obsoletes.

-------------------------------------------------------------------
Thu Feb 16 15:50:04 UTC 2017 - sndirsch@suse.com

- update to version 340.102
  * Added support for X.Org xserver ABI 23 (xorg-server 1.19)
  * Fixed a bug that allowed nvidia-installer to attempt loading 
    kernel modules that were built against non-running kernels.

-------------------------------------------------------------------
Mon Dec 12 10:20:39 UTC 2016 - sndirsch@suse.com

- update to version 340.101

-------------------------------------------------------------------
Mon Sep 26 09:01:49 UTC 2016 - sndirsch@suse.com

- update to version 340.98
  * Added support for the screen_info.ext_lfb_base field, on 
    kernels that have it, in order to properly handle UEFI 
    framebuffer consoles with physical addresses above 4GB.
- supersedes nvidia-kernel-4.6.diff

-------------------------------------------------------------------
Sat Jul 23 00:09:53 CEST 2016 - ro@suse.de

- change kver macro to have 3 digits for kernel micro version

-------------------------------------------------------------------
Sat Jul 23 00:01:07 CEST 2016 - ro@suse.de

- add patch nvidia-kernel-4.6.diff to allow build with kernel 4.6

-------------------------------------------------------------------
Tue Jun  7 16:28:12 UTC 2016 - sndirsch@suse.com

- fixed build and installation of kernel modules on target system

-------------------------------------------------------------------
Wed May 25 07:41:27 UTC 2016 - mmarek@suse.cz

- Fix the definition of the kver macro with non-default kernels

-------------------------------------------------------------------
Mon May 23 20:14:46 UTC 2016 - mmarek@suse.cz

- Fix build if the source tree is not /usr/src/linux (needed to
  build against kernel-source-vanilla or kernel-source-rt).

-------------------------------------------------------------------
Thu Feb 18 12:02:06 UTC 2016 - sndirsch@suse.com

- pci_ids: leap is considered newer than openSUSE 13.2

-------------------------------------------------------------------
Thu Nov 12 15:01:18 UTC 2015 - sndirsch@suse.com

- update to version 340.96

-------------------------------------------------------------------
Thu Sep  3 08:39:26 UTC 2015 - sndirsch@suse.com

- update to version 340.93
  * Fixed a bug that caused the X server to crash if an OpenGL application
    tried to allocate a drawable when GPU-accessible memory is exhausted.
  * Fixed a bug that could cause an Xid error when terminating a video
    playback application using the overlay presentation queue in VDPAU.
  * Updated nvidia-installer to avoid recursing too deeply into kernel source
    trees under /usr/lib/modules, mirroring an existing restriction on recursion
    under /lib/modules.
  * Fixed a rare deadlock condition when running applications that use
    OpenGL in multiple threads on a Quadro GPU.
  * Fixed a bug which caused truncation of the EGLAttribEXT value returned
    by eglQueryDeviceAttribEXT() on 64-bit systems.
  * Fixed a kernel memory leak that occurred when looping hardware-
    accelerated video decoding with VDPAU on Maxwell-based GPUs.
  * Fixed a bug that caused the X server to crash if a RandR 1.4 output
    provided by a Sink Output provider was selected as the primary output on
    X.Org xserver 1.17 and higher.
  * Fixed a bug that caused waiting on X Sync Fence objects in OpenGL to
    hang indefinitely in some cases.
  * Fixed a bug that prevented OpenGL from properly recovering from
    hardware errors or sync object waits that had timed out.
- supersedes nvidia-340.76-kernel-4.0.patch

-------------------------------------------------------------------
Tue Jun 16 13:49:05 UTC 2015 - sndirsch@suse.com

- added Obsoletes/Conflicts for G02 and older (bnc#802624) 

-------------------------------------------------------------------
Mon Jun 15 12:37:49 UTC 2015 - sndirsch@suse.com

- Avoid accidental removal of G<n+1> alternative (bnc#802624)

-------------------------------------------------------------------
Sat May  2 17:34:58 UTC 2015 - dmitry_r@opensuse.org

- Fix build with kernel 4.0
  * nvidia-340.76-kernel-4.0.patch

-------------------------------------------------------------------
Thu Apr  2 13:54:55 UTC 2015 - sndirsch@suse.com

- remove "multiversion(kernel)" from provides (bnc#925437)

-------------------------------------------------------------------
Thu Mar  5 11:59:28 UTC 2015 - sndirsch@suse.com

- added missing PCI IDs in sle11(bnc#920799), G04 (also covering 
  these) cannot be used for sle11!

-------------------------------------------------------------------
Mon Feb  2 11:55:02 UTC 2015 - sndirsch@suse.com

- created legacy pci_ids for openSUSE > 13.2

-------------------------------------------------------------------
Mon Feb  2 09:35:56 UTC 2015 - sndirsch@suse.com

- update to (meanwhile) legacy branch version 340.76
  * Fixed a bug that caused frequent AMD-Vi page faults on systems with
    some AMD 8xx/9xx-series chipsets when used with some NVIDIA GPUs.
  * Fixed a regression that could cause system crashes when terminating the
    X server on systems with an NVIDIA Quadro SDI Capture card installed.
  * Fixed a bug that caused audio over HDMI to not work on some GPUs while
    using a display that supports HDMI 3D.

-------------------------------------------------------------------
Fri Dec  5 10:31:12 UTC 2014 - mmarek@suse.cz

- update to latest long lived branch version 340.65
  * Fixed a bug that prevented internal 4K panels on some laptops
    from being driven at a sufficient bandwidth to support their
    native resolutions.
  * Fixed a regression that prevented the NVIDIA kernel module
    from loading in some virtualized environments such as Amazon
    Web Services.
  * Fixed a regression that caused displays to be detected
    incorrectly on some notebook systems.
  * Fixed a bug that could cause X to freeze when using Base
    Mosaic.
  * Fixed a regression that prevented the NVIDIA X driver from
    recognizing Base Mosaic layouts generated by the
    nvidia-settings control panel.

-------------------------------------------------------------------
Thu Nov  6 15:41:40 UTC 2014 - sndirsch@suse.com

- update to latest long lived branch version 340.58
  * Added support for the following GPUs:
    + GeForce GT820M
    + GeForce GTX 760A
    + GeForce GTX 850A
    + GeForce 810A
    + GeForce 820A
    + GeForce 840A
  * Fixed a bug that could cause VT-switching to fail following a
    suspend, resume, and driver reload sequence.
  * Fixed a bug that caused incorrect colors to be displayed on X
    screens running at depth 8 on some GPUs.
  * Fixed a bug that prevented GPUs from being correctly recognized
    in MetaMode strings when identified by UUID.
  * Implemented support for disabling indirect GLX context creation
    using the -iglx option available on X.Org server release 1.16
    and newer. Note that future X.Org server releases may make the
    -iglx option the default. To re-enable support for indirect GLX
    on such servers, use the +iglx option.
  * Added the "AllowIndirectGLXProtocol" X config option. This
    option can be used to disallow use of GLX protocol. See
    "Appendix B. X Config Options" in the README for more details.

-------------------------------------------------------------------
Thu Oct  2 11:48:02 UTC 2014 - sndirsch@suse.com

- update to latest long lived branch version 340.46
  * Fixed an OpenGL issue that could cause glReadPixels() operations to
    be improperly clipped when resizing composited application windows,
    potentially leading to momentary X freezes.
  * Fixed a bug that could prevent the GLSL compiler from correctly
    evaluating some expressions when compiling shaders.
  * Fixed a bug that could cause nvidia-installer to crash while attempting
    to run nvidia-xconfig on systems where that utility is missing.
  * Added option UseSysmemPixmapAccel to control the use of GPU acceleration
    for X drawing operations on pixmaps allocated in system memory.

-------------------------------------------------------------------
Thu Aug 14 09:06:00 UTC 2014 - sndirsch@suse.com

- update to latest long lived branch version 340.32
  * Added support for the following GPUs:
    + Quadro K420
    + Quadro K620
    + Quadro K2200
    + Quadro K4200
    + Quadro K5200
    + GeForce 830A
  * Fixed a regression that prevented the internal stereo infrared emitter
    built into some 3D Vision monitors from working.
  * Fixed a bug that could cause some Java-based OpenGL applications using
    JOGL to crash on startup on systems with Xinerama enabled.
  * Fixed a bug that could prevent OpenGL Framebuffer Objects (FBOs)
    from being properly redrawn after a modeswitch.
  * Fixed a memory leak that occurred when starting OpenGL applications.
  * Fixed a bug that prevented the EDID-Like Data (ELD) of audio-capable
    displays from being updated when hotplugged/unplugged.
  * Fixed a bug that caused Xid errors when using stereo mode 12 (HDMI 3D)
    on Quadro boards without an onboard stereo DIN connector.
  * Fixed a video corruption issue for VDPAU decoding of VC-1 and WMV
    video streams utilizing range remapping on Maxwell GPUs.
  * Fixed a "black window" bug in Ubuntu 14.04 when using the Xinerama
    and Composite extensions.
  * Fixed a bug that caused the screen's contents to be shifted downward when
    a G-SYNC monitor is unplugged and replaced by a non-G-SYNC monitor.
  * Fixed a bug that prevented G-SYNC from working when a G-SYNC monitor
    was unplugged and plugged back in without a modeset.

-------------------------------------------------------------------
Thu Aug  7 13:33:32 UTC 2014 - sndirsch@suse.com

- update to latest long lived branch version 340.24

-------------------------------------------------------------------
Fri Jul  4 09:43:25 UTC 2014 - sndirsch@suse.com

- updated to latest long lived branch version 331.89
  * Added support for the following GeForce GT 730
  * Fixed a race condition in the NVIDIA kernel module that caused 
    some GPUs to sporadically become unresponsive.
  * Updated the error reporting in the NVIDIA kernel module to 
    include the GPU serial number, when available, in error 
    messages written to the system log.
  * Fixed a bug that caused blank screens when transforming or 
    rotating displays in an SLI Mosaic layout.
  * Fixed a bug that corrupted certain software rendering on 32-bit 
    systems.

-------------------------------------------------------------------
Thu Jul  3 09:48:43 UTC 2014 - sndirsch@suse.com

- improve provides of kmp 

-------------------------------------------------------------------
Wed Jun 11 11:41:48 UTC 2014 - sndirsch@suse.com

- require the *flavor* KMP (bnc#881723)

-------------------------------------------------------------------
Fri Jun  6 13:30:08 UTC 2014 - sndirsch@suse.com

- get rid of the requirement to a specific kernel version
  (bnc#881723)

-------------------------------------------------------------------
Tue Jun  3 10:40:33 UTC 2014 - sndirsch@suse.com

- updated to latest long lived branch version 331.79
  * Fixed a bug that caused nvidia-installer to crash in environments
    where /proc is not mounted.
  * Fixed a bug that prevented module signing from working correctly
    for the NVIDIA Unified Memory kernel module when using module
    signing keys generated by nvidia-installer.
  * Fixed a bug that caused blank screens and flickering when rotating
    displays in a Base Mosaic layout.
  * Fixed a bug that caused BadRRCrtc or BadRROutput errors for big-endian
    X11 clients making certain XRandR requests.
  * Fixed a bug that corrupted certain software rendering, notably the
    stippled text used to represent disabled entries in xterm's pop-up menus.

-------------------------------------------------------------------
Mon Jun  2 13:08:46 UTC 2014 - sndirsch@suse.com

- autoselect to install also nvidia-uvm KMP; load nvidia-uvm in
  addition when nvidia module gets loaded; create the appropriate
  NVIDIA devices with the required permissions (bnc#879767)

-------------------------------------------------------------------
Wed May  7 15:15:12 UTC 2014 - sndirsch@suse.com

- update to latest long lived branch version 331.67
  * Fixed a bug that could lead to crashes when running Left 4 Dead 2
    with threaded optimizations enabled.
  * Added support for the following GPUs:
      * GeForce GT 705
      * GeForce GT 720
      * GeForce GTX 860M
      * GeForce GTX 870M
      * GeForce GTX 880M
  * Updated the makefile for the NVIDIA kernel module to work around a
    bug in older versions of GNU Make that prevented the NVIDIA kernel
    module from building correctly. This bug was fixed in version 3.81
    of GNU Make.
  * Fixed a bug that causes some X clients to be disconnected from the X
    server when the screen is resized while RandR 1.4 display offloading 
    is in use.
  * Fixed a bug that could cause display corruption when resuming from
    suspend on systems using RandR 1.4 display offloading with recent
    Linux kernels.
  * Added support for Tridelity SL stereo mode.
  * Fixed a bug that could cause nvidia-settings to crash or display
    incorrect information after switching virtual terminals while a
    color correction confirmation countdown was active.
  * Added a missing 32-bit compatibility library for
    libnvidia-fbc.so to the x86_64 Linux installer package.

-------------------------------------------------------------------
Mon May  5 09:24:42 UTC 2014 - sndirsch@suse.com

- kmp-post-uvm.sh: build Module.symvers properly before creating
  uvm module, so this file is no longer empty, symbols are no longer 
  undefined and uvm module can be loaded successfully
  (Andy Dick <adick@nvidia.com>)

-------------------------------------------------------------------
Fri Apr 11 12:47:20 UTC 2014 - sndirsch@suse.com

- disable signing of .ko file

-------------------------------------------------------------------
Thu Feb 13 09:58:38 UTC 2014 - sndirsch@suse.com

- created uvm KMP