File xf86-video-vesa.changes of Package xf86-video-vesa

-------------------------------------------------------------------
Fri Sep 11 10:07:38 UTC 2020 - Stefan Dirsch <sndirsch@suse.com>

- Update to version 2.5.0
  "This release rolls up a few minor bug fixes since 2.4.0. We now refuse
  to run on machines with UEFI firmware (on Linux only, patches welcome
  for other OSes) since it won't work in the general case and you
  probably have a kernel framebuffer driver running already. We also only
  attempt to use 24bpp if the alternative would be pseudocolor, but note
  that since xserver 1.20 24bpp will not work at all. If you'd like to
  fix that case, please note that it is filed as issue #4:

  https://gitlab.freedesktop.org/xorg/driver/xf86-video-vesa/-/issues/4

  We also notice several cases of running on emulated GPUs, in which case
  the shadow framebuffer is disabled by default to improve performance by
  reducing the number of copies.

  All users are recommended to upgrade, ideally to a better video card
  and/or driver."

-------------------------------------------------------------------
Fri Feb 16 14:46:06 UTC 2018 - sndirsch@suse.com

- Update to version 2.4.0
  * Nothing terribly exciting, but enough bug fixes to justify a
    release.
- supersedes u_Enable-DefaultRefresh-by-default.patch

-------------------------------------------------------------------
Mon May 29 14:59:03 UTC 2017 - sndirsch@suse.com

- includes everything needed for missing sle issue entries:
  fate #315643-315645, 319159-319161, 319618 (bsc#1041379)

-------------------------------------------------------------------
Tue Jul  5 09:53:39 UTC 2016 - eich@suse.com

- u_DPMS-Check-for-broken-DPMSGet.patch
  Check for broken DPMSGet (bsc#986974).

-------------------------------------------------------------------
Sun Sep 27 11:10:58 UTC 2015 - mpluskal@suse.com

- Add gpg signature

-------------------------------------------------------------------
Fri Sep 25 10:22:26 UTC 2015 - eich@suse.com

- u_DPMS-Query-DPMS-capabilites-and-query-current-state-before-changing.patch
  If the Xserver provides the VBEDPMSGetCapabilities() and VBEDPMSGet()
  API, check DPMS capabilities if a requested DPMS mode is supported before
  changing, and only change DPMS mode when the new state is different from 
  the old (bsc#947356, boo#947493). 

-------------------------------------------------------------------
Thu Jun 18 07:58:09 UTC 2015 - zaitor@opensuse.org

- Update to version 2.3.4:
  + configure: Drop PanelID test.
  + Don't include deprecated xf86PciInfo.h.
  + Raise required version of xorg-server to >= 1.6.

-------------------------------------------------------------------
Thu May 22 13:39:00 UTC 2014 - eich@suse.com

- u_Restore-palette-on-LeaveVT.patch:
  Restore the Palette on LeaveVT - as it is done on CloseScreen() already
  (bnc#719866).
- u_Enable-DefaultRefresh-by-default.patch:
  Update comments.

-------------------------------------------------------------------
Tue Sep 10 22:59:48 UTC 2013 - tobias.johannes.klausmann@mni.thm.de

- Update to version 2.3.3:
  A few cleanups, and a build fix for xserver 1.14.
  + Remove Upstreamed Patch1: U_mibstore.patch
  + Adapt Patch0: u_Enable-DefaultRefresh-by-default.patch (formerly
    known as xf86-video-vesa_DefaultRefresh.diff) to work with
    version 2.3.3

-------------------------------------------------------------------
Wed Aug  7 15:03:56 CEST 2013 - ro@suse.de

- add ExcludeArch for s390 and s390x 

-------------------------------------------------------------------
Tue Mar 19 10:20:02 UTC 2013 - hrvoje.senjan@gmail.com

- Add mibstore.patch, fixes build with xorg-server 1.14

-------------------------------------------------------------------
Sun Sep  2 19:26:30 UTC 2012 - zaitor@opensuse.org

- Update to version 2.3.2:
  + Add api 13 compat layer.
  + Convert to new screen conversion APIs.
  + Add missing compat-api header.

-------------------------------------------------------------------
Thu Apr 19 11:00:51 UTC 2012 - dimstar@opensuse.org

- Update to version 2.3.1:
  + Require a newer version of libpciaccess
  + Code style cleanup to make the map and unmap blocks more
    consistent
  + Build fix for ABI Version 12
  + Be forgiving of character-cell size mismatches in mode sizes
  + Fix memory leak in mode validation
  + Refuse to load if there's a kernel driver bound to the device
- Use %x11_abi_videodrv_req instead of static VIDEODRV_ABI requires

-------------------------------------------------------------------
Wed Apr 18 15:51:24 UTC 2012 - vuntz@opensuse.org

- Split xf86-video-vesa from xorg-x11-driver-video.
  Initial version: 2.3.0.
openSUSE Build Service is sponsored by