File ghc-hackage-security.changes of Package ghc-hackage-security

-------------------------------------------------------------------
Thu Mar 11 08:22:38 UTC 2021 - psimons@suse.com

- Update hackage-security to version 0.6.0.1 revision 5.
  Upstream has revised the Cabal build instructions on Hackage.

-------------------------------------------------------------------
Thu Dec 17 12:20:00 UTC 2020 - Ondřej Súkup <mimi.vx@gmail.com>
 
- disable %{ix86} build
 
-------------------------------------------------------------------
Fri Sep 18 02:00:44 UTC 2020 - psimons@suse.com

- Update hackage-security to version 0.6.0.1 revision 4.
  Upstream has revised the Cabal build instructions on Hackage.

-------------------------------------------------------------------
Wed Sep  2 02:00:58 UTC 2020 - psimons@suse.com

- Update hackage-security to version 0.6.0.1 revision 3.
  Upstream has revised the Cabal build instructions on Hackage.

-------------------------------------------------------------------
Mon Aug 31 09:34:36 UTC 2020 - psimons@suse.com

- Update hackage-security to version 0.6.0.1 revision 2.
  Upstream has revised the Cabal build instructions on Hackage.

-------------------------------------------------------------------
Tue Aug 18 10:44:56 UTC 2020 - Peter Simons <psimons@suse.com>

- Replace %setup -q with the more modern %autosetup macro.

-------------------------------------------------------------------
Tue Aug 18 09:28:33 UTC 2020 - Peter Simons <psimons@suse.com>

- Tweak Cabal file to accept latest version of base64-bytestring.

-------------------------------------------------------------------
Tue Jun 16 11:14:08 UTC 2020 - Peter Simons <psimons@suse.com>

- Re-generate file with latest version of spec-cleaner.

-------------------------------------------------------------------
Wed May  6 06:54:16 UTC 2020 - psimons@suse.com

- Update hackage-security to version 0.6.0.1.
  * Fix bug in non-default `-lukko` build-configuration (#242)
  * Add support for `template-haskell-2.16.0.0` (#240)
  * Remove `Hackage.Security.TUF.FileMap.lookupM`
  * Don't expose `Hackage.Security.Util.IO` module
  * Don't expose `Hackage.Security.Util.Lens` module
  * Report missing keys in `.meta` objects more appropriately as
    `ReportSchemaErrors(expected)` instead of via `Monad(fail)`
  * Add support for GHC 8.8 / base-4.13
  * Use `lukko` for file-locking
  * Extend `LogMessage` to signal events for cache lock acquiring and release
  * New `lockCacheWithLogger` operation

- Remove obsolete patch "fix-ghc-8.8.x-build.patch".

-------------------------------------------------------------------
Fri Feb 28 08:35:47 UTC 2020 - Peter Simons <psimons@suse.com>

- Update Cabal build information for more accurate dependencies.

------------------------------------------------------------------
Wed Jan  1 11:06:30 UTC 2020 - psimons@suse.com

- Apply "fix-ghc-8.8.x-build.patch" from head.hackage to fix the
  build with ghc-8.8.1.

-------------------------------------------------------------------
Fri Nov  8 16:13:48 UTC 2019 - Peter Simons <psimons@suse.com>

- Drop obsolete group attributes.

-------------------------------------------------------------------
Tue Jun 11 14:29:11 UTC 2019 - Peter Simons <psimons@suse.com>

- Update Cabal file for more accurate build dependencies.

-------------------------------------------------------------------
Fri Oct 19 18:38:52 UTC 2018 - Peter Simons <psimons@suse.com>

- Update Cabal build instructions to support ghc-8.6.1.

-------------------------------------------------------------------
Tue Aug  7 07:10:52 UTC 2018 - psimons@suse.com

- Update Cabal build information to support Cabal 2.4.x.

-------------------------------------------------------------------
Wed Jul 18 14:26:25 UTC 2018 - psimons@suse.com

- Cosmetic: replace tabs with blanks, strip trailing white space,
  and update copyright headers with spec-cleaner.

-------------------------------------------------------------------
Wed Jul 18 14:12:30 UTC 2018 - psimons@suse.com

- Revise cabal build file to specify more accurate dependencies.

-------------------------------------------------------------------
Mon May 14 17:02:11 UTC 2018 - psimons@suse.com

- Update hackage-security to version 0.5.3.0.
  * Use `flock(2)`-based locking where available
    (compat-shim taken from `cabal-install`'s code-base) (#207)
  * Improve handling of async exceptions (#187)
  * Detect & recover from local corruption of uncompressed index tarball (#196)
  * Support `base-4.11`

-------------------------------------------------------------------
Thu Aug  3 15:38:38 UTC 2017 - psimons@suse.com

- Updated with latest spec-cleaner version 0.9.8-8-geadfbbf.

-------------------------------------------------------------------
Mon May 22 08:08:49 UTC 2017 - psimons@suse.com

- Update to version 0.5.2.2 revision 4 with cabal2obs.

-------------------------------------------------------------------
Wed Apr 19 13:20:15 UTC 2017 - psimons@suse.com

- Update to version 0.5.2.2 revision 3 with cabal2obs.

-------------------------------------------------------------------
Mon Feb 20 08:42:31 UTC 2017 - psimons@suse.com

- Update to version 0.5.2.2 revision 2 with cabal2obs.

-------------------------------------------------------------------
Wed Dec 28 11:40:49 UTC 2016 - psimons@suse.com

- Update to version 0.5.2.2 revision 1 with cabal2obs.

-------------------------------------------------------------------
Fri Sep 16 21:16:02 UTC 2016 - psimons@suse.com

- Update to version 0.5.2.2 with cabal2obs.

-------------------------------------------------------------------
Sun Jul 10 17:19:31 UTC 2016 - psimons@suse.com

- Update to version 0.5.2.1 revision 0 with cabal2obs.

-------------------------------------------------------------------
Fri May 27 12:02:23 UTC 2016 - mimi.vx@gmail.com

- ghc-hackage-security generated by st2obs scritpt
openSUSE Build Service is sponsored by