File perl-Search-Elasticsearch-Client-6_0.spec of Package perl-Search-Elasticsearch-Client-6_0

#
# spec file for package perl-Search-Elasticsearch-Client-6_0
#
# Copyright (c) 2020 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


Name:           perl-Search-Elasticsearch-Client-6_0
Version:        6.80
Release:        0
%define cpan_name Search-Elasticsearch-Client-6_0
Summary:        Thin client with full support for Elasticsearch 6.x APIs
License:        This is free software, licensed under: The Apache License, Version 2.0, January 2004
Group:          Development/Libraries/Perl
Url:            https://metacpan.org/release/%{cpan_name}
Source0:        https://cpan.metacpan.org/authors/id/E/EZ/EZIMUEL/%{cpan_name}-%{version}.tar.gz
BuildArch:      noarch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  perl
BuildRequires:  perl-macros
BuildRequires:  perl(Devel::GlobalDestruction)
BuildRequires:  perl(Moo)
BuildRequires:  perl(Moo::Role)
BuildRequires:  perl(Search::Elasticsearch) >= 6.00
BuildRequires:  perl(Search::Elasticsearch::Role::API)
BuildRequires:  perl(Search::Elasticsearch::Role::Client::Direct)
BuildRequires:  perl(Search::Elasticsearch::Role::Is_Sync)
BuildRequires:  perl(Search::Elasticsearch::Util)
BuildRequires:  perl(Try::Tiny)
BuildRequires:  perl(namespace::clean)
Requires:       perl(Devel::GlobalDestruction)
Requires:       perl(Moo)
Requires:       perl(Moo::Role)
Requires:       perl(Search::Elasticsearch) >= 6.00
Requires:       perl(Search::Elasticsearch::Role::API)
Requires:       perl(Search::Elasticsearch::Role::Client::Direct)
Requires:       perl(Search::Elasticsearch::Role::Is_Sync)
Requires:       perl(Search::Elasticsearch::Util)
Requires:       perl(Try::Tiny)
Requires:       perl(namespace::clean)
%{perl_requires}

%description
The Search::Elasticsearch::Client::6_0 package provides a client compatible
with Elasticsearch 6.x. It should be used in conjunction with
Search::Elasticsearch as follows:

    $e = Search::Elasticsearch->new(
        client => "6_0::Direct"
    );

See Search::Elasticsearch::Client::6_0::Direct for documentation about how
to use the client itself.

%prep
%setup -q -n %{cpan_name}-%{version}

%build
perl Makefile.PL INSTALLDIRS=vendor
make %{?_smp_mflags}

%check
make test

%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist

%files -f %{name}.files
%defattr(-,root,root,755)
%doc Changes README
%license LICENSE

%changelog