File python-html5lib.changes of Package python-html5lib

-------------------------------------------------------------------
Mon Oct 14 13:39:22 UTC 2019 - Matej Cepl <mcepl@suse.com>

- Replace %fdupes -s with plain %fdupes; hardlinks are better.

-------------------------------------------------------------------
Fri Jul 19 12:28:28 UTC 2019 - Tomáš Chvátal <tchvatal@suse.com>

- Restrict pytest4 for now as upstream supports only 3 series
  at the moment

-------------------------------------------------------------------
Tue Dec  4 12:48:57 UTC 2018 - Matej Cepl <mcepl@suse.com>

- Remove superfluous devel dependency for noarch package

-------------------------------------------------------------------
Wed Dec 13 13:31:39 UTC 2017 - tchvatal@suse.com

- Version update to latest 1.0.1 release:
   * Dropped support for py 2.6
   * Documentation update
   * Fixes for python 3.7 and 3.6

-------------------------------------------------------------------
Tue Dec  5 16:42:07 UTC 2017 - opensuse@dstoecker.de

- update to 1.0b10

-------------------------------------------------------------------
Fri Apr  7 16:07:01 UTC 2017 - toddrme2178@gmail.com

- html5lib has a hard dependency on python-webencodings.
  It will fail at import time without it.

-------------------------------------------------------------------
Tue Apr  4 14:54:02 UTC 2017 - aloisio@gmx.com

- Updated to version 0.999999999 (see CHANGES.rst)
- Converted to single-spec
- Dropped coerce_comments_to_work_with_lxml.patch (accepted
  upstream)

-------------------------------------------------------------------
Fri Feb 12 14:54:04 UTC 2016 - toddrme2178@gmail.com

- Add coerce_comments_to_work_with_lxml.patch
  Fixes compatibility with python-lxml 3.5+, which adds validation
  for xml comments.
  Should be in next release/
- Re-enable tests.

-------------------------------------------------------------------
Tue Feb  2 11:46:24 UTC 2016 - toddrme2178@gmail.com

- Disable broken tests.
  Check if they are working again in the next release.

-------------------------------------------------------------------
Mon Feb  1 10:33:59 UTC 2016 - toddrme2178@gmail.com

- update to version 0.9999999:
  * Fix #195: fix the sanitizer to drop broken URLs (it threw an
    exception between 0.9999 and 0.999999).

-------------------------------------------------------------------
Mon Aug  3 16:30:05 UTC 2015 - tbechtold@suse.com

- Relax python-lxml BuildRequires and Requires. html5lib should
  also work with older python-lxml modules.

-------------------------------------------------------------------
Mon Jul 27 19:04:15 UTC 2015 - aloisio@gmx.com

- Update to version 0.999999
  * Fix #189: fix the sanitizer to allow relative URLs again
   (as it did prior to 0.9999/1.0b5).
- Aligned version requirements with PyPI

-------------------------------------------------------------------
Fri Jul 24 20:28:37 UTC 2015 - seife+obs@b1-systems.com

- Fix non-SUSE build by conditionalizing Recommends: tags

-------------------------------------------------------------------
Wed May  6 15:02:06 UTC 2015 - benoit.monin@gmx.fr

- update to version 0.99999:
  * Fix #188: fix the sanitizer to not throw an exception when
    sanitizing bogus data URLs.
- additional changes from version 0.9999:
  * Fix #153: Sanitizer fails to treat some attributes as URLs.
    Despite how this sounds, this has no known security
    implications. No known version of IE (5.5 to current), Firefox
    (3 to current), Safari (6 to current), Chrome (1 to current),
    or Opera (12 to current) will run any script provided in these
    attributes.
  * Pass error message to the ParseError exception in strict
    parsing mode.
  * Allow data URIs in the sanitizer, with a whitelist of
    content-types.
  * Add support for Python implementations that don’t support lone
    surrogates (read: Jython). Fixes #2.
  * Remove localization of error messages. This functionality was
    totally unused (and untested that everything was localizable),
    so we may as well follow numerous browsers in not supporting
    translating technical strings.
  * Expose treewalkers.pprint as a public API.
  * Add a documentEncoding property to HTML5Parser, fix #121.
- update project URL

-------------------------------------------------------------------
Mon May 26 22:01:47 UTC 2014 - hpj@urpla.net

- update to 0.999
  - Fix #127: add work-around for CPython issue #20007: .read(0) on
    http.client.HTTPResponse drops the rest of the content.
  - Fix #115: lxml treewalker can now deal with fragments containing, at their
    root level, text nodes with non-ASCII characters on Python 2.

- enable tests and include test suite for further validations
  for distributions > 11.1 and SLES 10

-------------------------------------------------------------------
Tue Oct 22 13:29:08 UTC 2013 - toddrme2178@gmail.com

- Update to 0.99
  * No changes, just updated version number
- Add additional dependencies

-------------------------------------------------------------------
Thu Mar 29 09:54:02 UTC 2012 - saschpe@suse.de

- Use upstream tarball
- Don't install tests, but install README

-------------------------------------------------------------------
Sat Feb 11 12:41:52 UTC 2012 - alexandre@exatati.com.br

- Update to 0.95:
  - Sorry, no changelog atm.
- Regenerate spec file with py2pack.

-------------------------------------------------------------------
Mon Jan 18 00:16:01 UTC 2010 - alexandre@exatati.com.br

- Update to 0.90.

-------------------------------------------------------------------
Wed Oct 14 16:53:20 UTC 2009 - alexandre@exatati.com.br

- Initial package (0.11.1) for openSUSE.