File python-hyper.changes of Package python-hyper

-------------------------------------------------------------------
Thu Sep 12 17:54:04 UTC 2019 - Tomáš Chvátal <tchvatal@suse.com>

- Add patch to fix http20 behaviour:
  * http20.patch
- Skip error reporting tests as they do not match httplib update

-------------------------------------------------------------------
Fri Jun 21 09:26:00 UTC 2019 - Bernhard Wiedemann <bwiedemann@suse.com>

- Add fix-j1-tests.patch to make build work on 1-core-VM

-------------------------------------------------------------------
Tue May 28 11:15:20 UTC 2019 - tchvatal@suse.com

- Skip one test that fails on TLS-1.3 because it is no longer
  supported openssl behaviour being tested

-------------------------------------------------------------------
Thu Mar 28 09:14:03 UTC 2019 - John Vandenberg <jayvdb@gmail.com>

- Add pr-402-http20-enable-push-fix.patch from upstream
  to fix http20 connection initialisation
- Improve fix-dependencies.patch removing upper constraints
- Merge hyper executable into main package
- Remove bcond test
- Simplify test invocation
- Add missing test dependency 'futures' on Python 2.7

-------------------------------------------------------------------
Wed Mar 27 15:55:40 UTC 2019 - jayvdb@gmail.com

- Update to version 0.7.0+git88.18b629b:
  * Add a fix to make it possible to add window_manager to HTTP20Adapter.
  * Add support for brotli compression
  * Fix crash on getting unsupported content-encoding
  * fix HTTP/1.1 response body length
  * fix HTTP/1.1 response body length
  * fix some error
  * Add test function for length of the HTTP/1.1 response-body.
  * fix HEAD request body length
  * fix test_release (http2bin to nghttp2.org/httpbin)

-------------------------------------------------------------------
Thu Apr 16 07:57 UTC 2018 - Martijn Goedhart <goedhart.martijn@gmail.com>

- Initial spec for version 0.7.0+git88.18b629b, adding
  fix-test.patch to de-vendor the tests and
  fix-dependencies.patch to unpin dependencies