File fix-detection-of-GCC5.patch of Package libqt4

--- a/configure	    2015-02-16 11:33:02.000000000 +0100
+++ b/configure	    2015-02-18 13:17:22.000000000 +0100
@@ -7729,7 +7729,7 @@ case "$XPLATFORM" in
     *-g++*)
 	# Check gcc's version
 	case "$(${QMAKE_CONF_COMPILER} -dumpversion)" in
-	    4*|3.4*)
+	    5*|4*|3.4*)
 		;;
             3.3*)
                 canBuildWebKit="no"
@@ -8031,6 +8031,11 @@ g++*)
         QT_GCC_MINOR_VERSION=`echo $COMPILER_VERSION | sed 's,^\([0-9]*\)\.\([0-9]*\).*,\2,'`
         QT_GCC_PATCH_VERSION=0
         ;;
+    *)
+        QT_GCC_MAJOR_VERSION=$COMPILER_VERSION
+        QT_GCC_MINOR_VERSION=0
+        QT_GCC_PATCH_VERSION=0
+        ;;
     esac
 
     case "$COMPILER_VERSION" in
@@ -8040,7 +8045,7 @@ g++*)
     3.*)
         COMPILER_VERSION="3.*"
         ;;
-    4.*)
+    5*|4.*)
         COMPILER_VERSION="4"
         ;;
     *)
openSUSE Build Service is sponsored by