File libgloox.spec of Package libgloox

#
# spec file for package libglox (Version 0.9.9.12)
#
# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild  
  
%define soname	7  
  
Name:           libgloox
Version:        0.9.9.12 
Release:        1  
Summary:        High-level XMPP Library for C++  
Source:         http://camaya.net/download/gloox-%{version}.tar.bz2  
Patch0:         gloox-missing-include.patch  
URL:            http://camaya.net/gloox  
Group:          Development/Libraries/C and C++  
License:        GPLv2+  
BuildRoot:      %{_tmppath}/build-%{name}-%{version}  
BuildRequires:  gcc-c++ make pkg-config
BuildRequires:  autoconf automake libtool
BuildRequires:  libiksemel-devel
BuildRequires:  libgnutls-devel
BuildRequires:  libidn-devel
BuildRequires:  zlib-devel
  
%description  
gloox is a portable high-level Jabber/XMPP library for C++. It is fully  
compliant with the XMPP RFCs, supports all of the XMPP features (including  
SRV lookups, TLS, SASL, roster management, and privacy lists), and implements  
several XEPs that make it ideal for writing any kind of Jabber/XMPP client  
or component.  

%package -n %{name}%{soname}
Summary:        High-level XMPP Library for C++  
Group:          Development/Libraries/C and C++
License:        GPLv2+
Provides:       %{name} = %{version}
Obsoletes:      %{name} < %{version} 

%description -n %{name}%{soname}
gloox is a portable high-level Jabber/XMPP library for C++. It is fully  
compliant with the XMPP RFCs, supports all of the XMPP features (including  
SRV lookups, TLS, SASL, roster management, and privacy lists), and implements  
several XEPs that make it ideal for writing any kind of Jabber/XMPP client  
or component.  

%package devel  
Summary:        High-level XMPP Library for C++  
Group:          Development/Libraries/C and C++
License:        GPLv2+ 
Requires:       %{name}%{soname} = %{version}-%{release}
Requires:       libstdc++-devel
Requires:       libiksemel-devel
Requires:       libgnutls-devel
Requires:       libidn-devel
Requires:       zlib-devel
  
%description devel  
gloox is a portable high-level Jabber/XMPP library for C++. It is fully  
compliant with the XMPP RFCs, supports all of the XMPP features (including  
SRV lookups, TLS, SASL, roster management, and privacy lists), and implements  
several XEPs that make it ideal for writing any kind of Jabber/XMPP client  
or component.  
  
%prep  
%setup -q -n "gloox-%{version}"  
%patch0
  
%build  
%configure --disable-static --with-pic
make %{?_smp_mflags}
  
%install  
%makeinstall  
rm -rf %{buildroot}/%{_libdir}/%{name}.la  
  
%clean  
rm -rf "%{buildroot}"  
  
%post -n %{name}%{soname} -p /sbin/ldconfig  
  
%postun -n %{name}%{soname} -p /sbin/ldconfig  
  
%files -n %{name}%{soname}
%defattr(-,root,root)  
%doc AUTHORS README ChangeLog TODO  
%{_libdir}/libgloox.so.%{soname}  
%{_libdir}/libgloox.so.%{soname}*  
  
%files -n %{name}-devel  
%defattr(-,root,root)  
%{_bindir}/gloox-config  
%{_includedir}/gloox  
%{_libdir}/libgloox.so  
%{_libdir}/pkgconfig/gloox.pc  
  
%changelog
openSUSE Build Service is sponsored by