LogoopenSUSE Build Service > Projects
Sign Up | Log In

View File 0651-No-longer-warn-for-use-of-the-overload-module.patch of Package erlang (Project home:Ledest:erlang:20)

From e92005be1bd88114de86dafb76c595248827241b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Bj=C3=B6rn=20Gustavsson?= <bjorn@erlang.org>
Date: Thu, 4 Apr 2019 05:47:57 +0200
Subject: [PATCH 2/5] No longer warn for use of the overload module

The entire overload module was removed in OTP 19. Stopping warning
for it now, since the module name could be used by code outside
OTP.
---
 lib/stdlib/src/otp_internal.erl | 2 --
 1 file changed, 2 deletions(-)

diff --git a/lib/stdlib/src/otp_internal.erl b/lib/stdlib/src/otp_internal.erl
index f31356968e..25069a3db3 100644
--- a/lib/stdlib/src/otp_internal.erl
+++ b/lib/stdlib/src/otp_internal.erl
@@ -467,8 +467,6 @@ obsolete_1(queue, lait, 1) ->
 
 %% Removed in OTP 19.
 
-obsolete_1(overload, _, _) ->
-    {removed, "removed in OTP 19"};
 obsolete_1(rpc, safe_multi_server_call, A) when A =:= 2; A =:= 3 ->
     {removed, {rpc, multi_server_call, A}, "removed in OTP 19"};
 
-- 
2.16.4