File gparted.spec of Package gparted

#
# spec file for package gparted
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           gparted
Version:        0.33.0
Release:        0
Summary:        Gnome Partition Editor
License:        GPL-2.0
Group:          System/Filesystems
Url:            http://gparted.sourceforge.net/
Source0:        http://downloads.sourceforge.net/project/gparted/gparted/gparted-%{version}/%{name}-%{version}.tar.gz
Source1:        http://downloads.sourceforge.net/project/gparted/gparted/gparted-%{version}/%{name}-%{version}.tar.gz.sig
Source98:       %{name}.policy
Source99:       %{name}.keyring
BuildRequires:  e2fsprogs-devel
BuildRequires:  fdupes
BuildRequires:  gcc-c++
BuildRequires:  gnome-doc-utils-devel
BuildRequires:  intltool
BuildRequires:  parted-devel
BuildRequires:  perl-XML-Parser
BuildRequires:  polkit
BuildRequires:  scrollkeeper
%if !0%{?is_opensuse}
BuildRequires:  translation-update-upstream
%endif
BuildRequires:  update-desktop-files
BuildRequires:  xfsprogs-devel
BuildRequires:  pkgconfig(glibmm-2.4) >= 2.14.0
BuildRequires:  pkgconfig(gtkmm-2.4) >= 2.16.0
BuildRequires:  pkgconfig(gthread-2.0)
BuildRequires:  pkgconfig(sigc++-2.0) >= 2.5.1
Requires:       btrfsprogs >= 4.1
Requires:       cryptsetup
Requires:       e2fsprogs
Requires:       hdparm
Requires:       hfsutils
Requires:       jfsutils
Requires:       mtools
Requires:       nilfs-utils
Requires:       ntfsprogs
Requires:       parted
Requires:       polkit
Requires:       reiserfs
Requires:       util-linux
Requires:       xdg-utils
Requires:       xfsprogs
Recommends:     gpart
Recommends:     udftools
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
GParted is an industrial-strength package for creating, destroying, resizing,
moving, checking and copying partitions, and the filesystems on them. This is
useful for creating space for new operating systems, reorganizing disk usage,
copying data residing on hard disks and mirroring one partition with another
(disk imaging).

%lang_package
%prep
%setup -q
%if !0%{?is_opensuse}
translation-update-upstream
%endif

%build
export GKSUPROG="pkexec"
%configure \
	--disable-scrollkeeper \
	--enable-xhost-root
make %{?_smp_mflags}

%install
%make_install

install -Dm0644 %{S:98} %{buildroot}%{_datadir}/polkit-1/actions/org.opensuse.policykit.%{name}.policy
# Here we remove upstream policy file since we have our own
rm %{buildroot}%{_datadir}/polkit-1/actions/org.gnome.%{name}.policy

%suse_update_desktop_file %{name}
%fdupes %{buildroot}%{_datadir}
%find_lang %{name} %{?no_lang_C}

%files
%defattr(-,root,root)
%doc README ChangeLog AUTHORS NEWS COPYING
%{_bindir}/%{name}
%{_sbindir}/%{name}bin
%{_mandir}/man8/%{name}.8.gz
%dir %{_datadir}/appdata
%{_datadir}/appdata/%{name}.appdata.xml
%{_datadir}/applications/%{name}.desktop
%{_datadir}/icons/hicolor/*x*/apps/%{name}.png
%{_datadir}/icons/hicolor/scalable/apps/%{name}.svg
%{_datadir}/polkit-1/actions/org.opensuse.policykit.%{name}.policy
#{_datadir}/polkit-1/actions/org.gnome.%%{name}.policy
%dir %{_datadir}/gnome
%dir %{_datadir}/gnome/help
%dir %{_datadir}/gnome/help/%{name}
%doc %{_datadir}/gnome/help/%{name}/C/
%dir %{_datadir}/omf
%doc %{_datadir}/omf/%{name}/%{name}-C.omf

%files lang -f %{name}.lang

%changelog