File libdatrie-doxygen-version-check.patch of Package libdatrie

--- libdatrie-0.2.8/configure.ac	2014-01-10 05:20:37.000000000 +0100
+++ libdatrie-0.2.8/configure.ac	2015-08-18 16:42:15.274113614 +0200
@@ -112,12 +112,9 @@ if test "x$enable_doxygen_doc" = "xyes";
   else
     AC_MSG_CHECKING([doxygen >= $DOXYGEN_REQ_VER])
     DOXYGEN_VER=$($DOXYGEN --version)
-    if expr $DOXYGEN_VER \< $DOXYGEN_REQ_VER > /dev/null; then
-      AC_MSG_RESULT([$DOXYGEN_VER, no, documentation disabled])
-      enable_doxygen_doc="no"
-    else
-      AC_MSG_RESULT([$DOXYGEN_VER, yes])
-    fi
+    AX_COMPARE_VERSION([$DOXYGEN_VER],[ge],[DOXYGEN_REQ_VER], 
+                       [AC_MSG_RESULT([$DOXYGEN_VER, yes])], 
+                       [AC_MSG_RESULT([$DOXYGEN_VER, no, documentation disabled]); enable_doxygen_doc="no"])
   fi
 fi