LogoopenSUSE Build Service > Projects
Sign Up | Log In

View File perl-Module-Build.changes of Package perl-Module-Build (Project home:aeneas_jaissle:sewikom)

-------------------------------------------------------------------
Sun May 17 08:20:57 UTC 2015 - coolo@suse.com

- updated to 0.4212
   see /usr/share/doc/packages/perl-Module-Build/Changes

  0.4212 - Sun May 17 00:33:34 CEST 2015
  
    [BUG FIXES]
  
    - Revert "Stop using version->normal(); prefer stringify()"

-------------------------------------------------------------------
Thu Apr 16 13:30:39 UTC 2015 - coolo@suse.com

- expanding the version to 6 digits after . - to avoid version mismatches

-------------------------------------------------------------------
Tue Feb  3 16:07:00 UTC 2015 - coolo@suse.com

- add make-builds-reproducible.patch to sort the config data

-------------------------------------------------------------------
Tue Feb  3 15:55:41 UTC 2015 - coolo@suse.com

- updated to 0.4211
   [BUG FIXES]
   - Fix t/actions/installdeps.t to work on "perl in space" [Ed J]
   - Stop using version->normal(); prefer stringify() [John Peacock]
 
   [DEPRECATIONS]
   - inc::latest has been split out to a separate distribution on CPAN.
     It is an optional prerequisite, only needed for the experimental
     bundling feature.

-------------------------------------------------------------------
Sun Dec 21 21:07:03 UTC 2014 - lars@linux-schulserver.de

- update to 0.4210:
  [BUG FIXES]
  - Formally declare 5.8 dependency [Karen Etheridge]
  - Fix MBTest to work with new and old versions of Test::Builder [Chad Granum]
  - Fix type installdir -> installdirs [Leon Timmermans, Vitaliy Tokarev]
  - Removed missed references to Module::Build::Version
  - Stop calling UNIVERSAL::isa as a function
  - Fixup CPAN::Meta dependency
  - Handle old releases of CPAN::Meta more gracefully.
  [ENHANCEMENTS]
  - Enable release and author tests during disttest [Leon Timmermans, Alberto Simões]
  - Use CPAN::Meta::Merge for meta_merge
  - Convert with CPAN::Meta::Convert in meta_add
  - Add configure requirements
  [DEPRECATIONS]
  - Module::Build::YAML has been removed
  - Module::Build::ModuleInfo has been removed
  - Module::Build::Version has been removed
  - Get rid of "use vars"
  - Added use warnings to all modules

- use local lib in lib/Module/Build/Base.pm

-------------------------------------------------------------------
Sun Feb 16 20:04:04 UTC 2014 - lars@linux-schulserver.de

- update to 0.4205:
  [BUG FIXES]
  - FIX license code regression for artistic license
  - Don't swallow ExtUtils::CBuilder loading errors
  - Handle testing on cross-compile builds
  - Protect against platforms without getpw{nam,uid}

-------------------------------------------------------------------
Fri Jan 17 21:04:12 UTC 2014 - lars@linux-schulserver.de

- update to 0.4204:
  [BUG FIXES]
  - Map conflicts back to runtime [Leon Timmermans]
  - Use mod2fname whenever it's available [Leon Timmermans, Brian Fraser]
  - Accept custom entries in meta_merge 1.4

-------------------------------------------------------------------
Tue Dec 10 06:36:39 UTC 2013 - coolo@suse.com

- updated to 0.4203
   [BUG FIXES]
   - Map recommends back to runtime recommends [Leon Timmermans]
   - Map restrictive license to restricted in meta 2.0 [Leon Timmermans]
   - Don't merge prereqs from meta to mymeta [Leon Timmermans]
   - Prefer META.json over META.yml [Leon Timmermans]
   - Do not set provides in metadata if no_index is set [Leon Timmermans]
   - Lowercase license in fallback logic [Leon Timmermans]
 
   [ENHANCEMENTS]
   - Converted to using Meta 2.0
 
-------------------------------------------------------------------
Tue Oct  8 06:47:23 UTC 2013 - coolo@suse.com

- updated to 0.4007
   [BUG FIXES]
 
   - Removed undeclared test dependency on parent.pm [Leon Timmermans]
 
   - Declared dependency on Pod::Man 2.17 for utf8 support [Leon Timmermans]
 
   - Force generation of man pages in manify_with_utf8.t [Leon Timmermans]
 
 0.4006 - Thu Jul 18 14:19:49 CEST 2013
 
   [ENHANCEMENTS]
 
   - Significantly sped up some tests by not forcing HTML docs to be
     built when the user's config doesn't ask for them anyway.
     [Ken Williams]
 
   - The Module::Metadata package was split out from this distro back
     in 2010.  Removed its regression tests. [Ken Williams]
 
   - Removed dependence on IO::File, replacing it with safe invocations
     of open(). [Sven Dowideit]
 
   - Added an 'extra_manify_args' parameter to facilitate man pages
     containing Unicode. [Joenio Costa]
 
   - Added an '--html_links 0' argument for the 'html' action, which
     can hugely speed things up.  The main effect is speeding up the
     M::B tests themselves. [Ken Williams]
 
   [BUG FIXES]
 
   - Fix hash argument parsing in subclasses [Graham Ollis]
 
   - Revised detildification on VMS [Craig Berry]
 
   - Fix run_test_harness for case when $Switches is an empty string
     [Victor Efimov, Ken Williams]
 

-------------------------------------------------------------------
Thu Jun 27 09:28:27 UTC 2013 - coolo@suse.com

- add more of the required modules

-------------------------------------------------------------------
Tue Jun 27 09:07:21 UTC 2013 - lnt-sysadmin@lists.lrz.de

- added perl(Module::Metadata) as dependency

-------------------------------------------------------------------
Tue Jun 11 13:13:38 UTC 2013 - coolo@suse.com

- updated to 0.4005
   [ENHANCEMENTS]
 
   - Added --pureperl-only support
 
   [BUG FIXES]
 
   - #72176: pod2html will fail with an empty podpath in some cases. [Phillip Moore]
 
   - Fix links between modules in HTML docs output [Michael Wild, Leon Timmermans]
 
   [BUG FIXES]
 
   - Minor VMS fix for @INC [Craig Berry]
 
   [ENHANCEMENTS]
 
   - test_requires support has been added [Matsuno Tokuhiro]

-------------------------------------------------------------------
Thu Oct 25 17:13:01 UTC 2012 - opensuse@dstoecker.de

- fix requirements for building on older suse versions

-------------------------------------------------------------------
Wed Sep 19 21:44:29 UTC 2012 - opensuse@dstoecker.de

- update to 0.4003

-------------------------------------------------------------------
Wed Aug 17 17:42:00 UTC 2011 - chris@computersalat.de

- fix deps for RHEL, CentOS

-------------------------------------------------------------------
Fri Dec  3 07:46:55 UTC 2010 - seife@opensuse.org

- change version to 0.36.07 to prevent rpm version compare problems

-------------------------------------------------------------------
Thu Dec  2 15:35:10 UTC 2010 - seife@opensuse.org

- fix conflict of config_data with the perl-supplied one by
  renaming it to config_data-${version}

-------------------------------------------------------------------
Thu Dec  2 15:03:31 UTC 2010 - seife@opensuse.org

- update to 0.3607. Fixes:
  - The 'dist' action now always ensures a clean dist directory
    before creating the tarball
  - Added missing newline to "Changing sharpbang" messages under
    verbose output (RT#54474)
  - Support anonymous array of directories for c_source
  - Small POD formatting fix
  - Module::Build::Compat would croak on distibutions that set
    requires 'perl' to a dotted decimal like '5.6.2'.
  - When the currently running Module::Build is not the same as the
    one that created the Build file, there is now a warning rather
    than a fatal error.

-------------------------------------------------------------------
Wed Dec  1 13:33:42 UTC 2010 - coolo@novell.com

- switch to perl_requires macro

-------------------------------------------------------------------
Tue Sep 14 20:59:25 UTC 2010 - chris@computersalat.de

- update to 0.36
  o just for SLE_10 :)
- noarch pkg

-------------------------------------------------------------------
Thu Mar  4 15:42:00 UTC 2010 - chris@computersalat.de

- add again obviously removed package
  o BuildReq by e.g. Test::Pod for SLE_10 

-------------------------------------------------------------------
Sat Jul 25 19:40:56 CEST 2009 - chris@computersalat.de

- spec mods
  * removed ^----------
  * removed ^#---------

-------------------------------------------------------------------
Tue Jun 23 01:10:42 CEST 2009 - chris@computersalat.de

- initial package 0.31