LogoopenSUSE Build Service > Projects
Sign Up | Log In

View File libkgeomap.spec of Package libkgeomap (Project home:alarrosa:SLE12SP2_from42.2:Applications)

#
# spec file for package libkgeomap
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           libkgeomap
Summary:        Wrapper around different world-map components
License:        LGPL-2.1 and GPL-2.0+
Group:          Development/Libraries/KDE
Url:            http://www.kde.org
Version:        16.08.2
Release:        0
Source0:        %{name}-%{version}.tar.xz
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  extra-cmake-modules
BuildRequires:  kconfig-devel
BuildRequires:  ki18n-devel
BuildRequires:  kio-devel
BuildRequires:  libkexiv2-devel
BuildRequires:  marble-devel
BuildRequires:  pkgconfig(Qt5Concurrent)
BuildRequires:  pkgconfig(Qt5Core)
BuildRequires:  pkgconfig(Qt5Gui)
BuildRequires:  pkgconfig(Qt5Test)
BuildRequires:  pkgconfig(Qt5WebKitWidgets)
BuildRequires:  pkgconfig(Qt5Widgets)
BuildRequires:  pkgconfig(Qt5Xml)
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Obsoletes:      libkgeomap-kf5 < %{version}
Provides:       libkgeomap-kf5 = %{version}
Requires:       libKF5KGeoMap10_0_0 = %version

%description
Libkgeomap is a wrapper around different world-map components, to browse and arrange photos over a map.
Currently supported map engine are:
- Marble, 
- OpenstreetMap (via Marble),
- GoogleMap,
This library is used by kipi-plugins, digiKam and other kipi host programs

%prep
%setup -q -n %{name}-%{version}

%build
  %cmake_kf5 -d build
  %make_jobs

%install
  %kf5_makeinstall -C build

%clean
  rm -rf $RPM_BUILD_ROOT

%package -n libKF5KGeoMap10_0_0
Summary:        Wrapper around different world-map components
Group:          Development/Libraries/KDE
Recommends:     marble5

%description -n libKF5KGeoMap10_0_0
Libkgeomap is a wrapper around different world-map components, to browse and arrange photos over a map.
Currently supported map engine are:
- Marble, 
- OpenstreetMap (via Marble),
- GoogleMap,
This library is used by kipi-plugins, digiKam and other kipi host programs

%post -n libKF5KGeoMap10_0_0 -p /sbin/ldconfig

%postun -n libKF5KGeoMap10_0_0 -p /sbin/ldconfig

%package devel
Summary:        Wrapper around different world-map components
Group:          Development/Libraries/KDE
Requires:       libKF5KGeoMap10_0_0 = %version
Obsoletes:      libkgeomap-kf5-devel < %{version}
Provides:       libkgeomap-kf5-devel = %{version}
Requires:       kconfig-devel
Requires:       ki18n-devel
Requires:       marble-devel
Requires:       pkgconfig(Qt5Concurrent)
Requires:       pkgconfig(Qt5Core)
Requires:       pkgconfig(Qt5Gui)
Requires:       pkgconfig(Qt5WebKitWidgets)
Requires:       pkgconfig(Qt5Widgets)
Requires:       pkgconfig(Qt5Xml)

%description devel
Libkgeomap is a wrapper around different world-map components, to browse and arrange photos over a map.
Currently supported map engine are:
- Marble, 
- OpenstreetMap (via Marble),
- GoogleMap,
This library is used by kipi-plugins, digiKam and other kipi host programs

%files devel
%defattr(-,root,root)
%doc COPYING README
%_libdir/cmake/KF5KGeoMap/
%_kf5_includedir/libkgeomap_version.h
%_kf5_includedir/KGeoMap/
%_libdir/libKF5KGeoMap.so

%files -n libKF5KGeoMap10_0_0
%defattr(-,root,root)
%doc COPYING.LIB README
%_libdir/libKF5KGeoMap.so.*

%files
%defattr(-,root,root)
%doc COPYING README
%_datadir/libkgeomap/

%changelog