File kde-runtime-glib2-include.patch of Package kdebase4-runtime

Index: kde-runtime-15.08.0/CMakeLists.txt
===================================================================
--- kde-runtime-15.08.0.orig/CMakeLists.txt
+++ kde-runtime-15.08.0/CMakeLists.txt
@@ -57,6 +57,13 @@ set_package_properties(LibGcrypt PROPERT
                        TYPE REQUIRED
                        PURPOSE "kwalletd needs libgcrypt to perform PBKDF2-SHA512 hashing"
                       )
+
+find_package(GLIB2)
+set_package_properties(GLIB2 PROPERTIES DESCRIPTION "Low-level core library for data structure handling, portability wrappers, etc."
+                       URL "http://www.gtk.org"
+                       TYPE OPTIONAL
+                      )
+
 # Build options
 option(KDERUNTIME_BUILD_NEPOMUK "Build the Nepomuk KCM and kioslaves" FALSE)
 
Index: kde-runtime-15.08.0/phonon/kcm/CMakeLists.txt
===================================================================
--- kde-runtime-15.08.0.orig/phonon/kcm/CMakeLists.txt
+++ kde-runtime-15.08.0/phonon/kcm/CMakeLists.txt
@@ -5,12 +5,6 @@ set_package_properties(PulseAudio PROPER
                        PURPOSE "libpulse is needed for audio setup GUI"
                       )
 
-find_package(GLIB2)
-set_package_properties(GLIB2 PROPERTIES DESCRIPTION "Low-level core library for data structure handling, portability wrappers, etc."
-                       URL "http://www.gtk.org"
-                       TYPE OPTIONAL
-                      )
-
 pkg_check_modules(CANBERRA libcanberra)
 add_feature_info ("Audio setup GUI" CANBERRA_FOUND
                   "libcanberra is needed for audio setup GUI
Index: kde-runtime-15.08.0/solid-networkstatus/CMakeLists.txt
===================================================================
--- kde-runtime-15.08.0.orig/solid-networkstatus/CMakeLists.txt
+++ kde-runtime-15.08.0/solid-networkstatus/CMakeLists.txt
@@ -1,2 +1,3 @@
+include_directories(${GLIB2_INCLUDE_DIR})
 add_subdirectory(kded)
 add_subdirectory(tests)