File python-xlrd.changes of Package python-xlrd

-------------------------------------------------------------------
Sat Dec 22 05:47:20 UTC 2018 - Todd R <toddrme2178@gmail.com>

- Update to 1.2.0
  * Added support for Python 3.7.
  * Added optional support for defusedxml to help mitigate exploits.
  * Automatically convert ``~`` in file paths to the current user's home
    directory.
  * Removed ``examples`` directory from the installed package. They are still
    available in the source distribution.
  * Fixed ``time.clock()`` deprecation warning.

-------------------------------------------------------------------
Wed Aug  8 16:24:55 UTC 2018 - jengelh@inai.de

- Use noun phrase in summary again.

-------------------------------------------------------------------
Wed Jun 13 16:56:47 UTC 2018 - toddrme2178@gmail.com

- Update to 1.1.0
  * Fix for parsing of merged cells containing a single cell reference in xlsx
    files.
  * Fix for "invalid literal for int() with base 10: 'true'" when reading some
    xlsx files.
  * Make xldate_as_datetime available to import direct from xlrd.
  * Build universal wheels.
  * Sphinx documentation.
  * Document the problem with XML vulnerabilities in xlsx files and mitigation
    measures.
  * Fix :class:`NameError` on ``has_defaults is not defined``.
  * Some whitespace and code style tweaks.
  * Make example in README compatible with both Python 2 and 3.
  * Add default value for cells containing errors that causeed parsing of some
    xlsx files to fail.
  * Add Python 3.6 to the list of supported Python versions, drop 3.3 and 2.6.
  * Use generator expressions to avoid unnecessary lists in memory.
  * Document unicode encoding used in Excel files from Excel 97 onwards.
  * Report hyperlink errors in R1C1 syntax.

-------------------------------------------------------------------
Wed May  3 14:53:22 UTC 2017 - toddrme2178@gmail.com

- Fix license
- Executable is python version independent so make it python3-only.

-------------------------------------------------------------------
Wed Apr 19 22:13:57 UTC 2017 - toddrme2178@gmail.com

- Source url must be https.

-------------------------------------------------------------------
Tue Apr 18 16:19:23 UTC 2017 - toddrme2178@gmail.com

- Update to 1.0.0
  * Official support, such as it is, is now for 2.6, 2.7, 3.3+
  * Fixes a bug in looking up non-lowercase sheet filenames by
    ensuring that the sheet targets are transformed the same way
    as the component_names dict keys.
  * Fixes a bug for ragged_rows=False when merged cells increases
    the number of columns in the sheet. This requires all rows
    to be extended to ensure equal row lengths that match the
    number of columns in the sheet.
  * Fixes to enable reading of SAP-generated .xls files.
  * support BIFF4 files with missing FORMAT records.
  * support files with missing WINDOW2 record.
  * Empty cells are now always unicode strings, they were a
    bytestring on Python 2 and a unicode string on Python 3.
  * Fix for <cell> inlineStr attribute without <si> child.
  * Fix for a zoom of None causing problems on Python 3.
  * Fix parsing of bad dimensions.
  * Fix xlsx sheet to comments relationship.
- Implement single-spec version.

-------------------------------------------------------------------
Thu Oct 29 17:54:20 UTC 2015 - scorot@free.fr

- Update to 0.9.4
  * No changelog available 

-------------------------------------------------------------------
Tue Apr 30 11:34:15 UTC 2013 - toddrme2178@gmail.com

- Remove unnecessary .py extension from executable
- Fix python2/python3 executable name conflict

-------------------------------------------------------------------
Tue Apr 16 18:52:07 UTC 2013 - jfunk@funktronics.ca

- Update to 0.9.2:
  - Bug fixes
- Changes from 0.9.1:
  * Removed support for Python < 2.6
  * Bug fixes
- Changes from 0.9.0:
  * Python3 support
  * Expanded tests
  * Bug fixes
- Spec cleanup

-------------------------------------------------------------------
Tue Nov 13 22:55:36 UTC 2012 - jfunk@funktronics.ca

- Update to 0.8.0
  * This release finally lands the support for both .xls and .xlsx files. Many
    thanks to John Machin for all his work on making this happen. Opening of
    .xlsx files is seamless, just use xlrd as you did before and it all should
    "just work".
  * xlrd 0.8.0 is also the first release that that targets Python 2.6 and 2.7,
    but no Python 3 just yet. Python 2.5 and below may work but are not
    supported. If you need to use Python 2.5 or earlier, please stick to xlrd
    0.7.x.

-------------------------------------------------------------------
Fri Apr 27 23:16:13 UTC 2012 - jfunk@funktronics.ca

- Update to 0.7.7
  * Changelog information unavailable

-------------------------------------------------------------------
Fri Apr  6 19:26:00 UTC 2012 - jfunk@funktronics.ca

- Update to 0.7.6:
  * Changelog information unavailable

-------------------------------------------------------------------
Tue Feb 28 18:13:47 UTC 2012 - jfunk@funktronics.ca

- Update to 0.7.3

-------------------------------------------------------------------
Tue Feb 21 20:05:14 UTC 2012 - jfunk@funktronics.ca

- Update to 0.7.2
- Update spec for current conventions

-------------------------------------------------------------------
Wed May 12 13:02:43 UTC 2010 - jfunk@funktronics.ca

- Initial release