LogoopenSUSE Build Service > Projects
Sign Up | Log In

View File use-pycodestyle-instead-of-pep8.patch of Package mycroft-core (Project home:alarrosa:packages)

From: Antonio Larrosa <larrosa@kde.org>
Subject: Update requirements to python3

Remove requirements that are not required on python3
and renamed pep8 to pycodestyle
Index: mycroft-core-release-v0.9.16/requirements.txt
===================================================================
--- mycroft-core-release-v0.9.16.orig/requirements.txt
+++ mycroft-core-release-v0.9.16/requirements.txt
@@ -2,14 +2,14 @@ six==1.10.0
 requests==2.13.0
 gTTS==1.1.7
 gTTS-token==1.1.1
-backports.ssl-match-hostname==3.4.0.2
+#backports.ssl-match-hostname==3.4.0.2
 PyAudio==0.2.11
 pyee==1.0.1
 SpeechRecognition==3.8.1
 tornado==4.2.1
 websocket-client==0.32.0
 adapt-parser==0.3.0
-futures==3.0.3
+#futures==3.0.3
 future==0.16.0
 requests-futures==0.9.5
 parsedatetime==1.5
@@ -29,7 +29,7 @@ google-api-python-client==1.6.4
 monotonic
 
 # dev setup tools
-pep8==1.7.0
+pycodestyle==1.7.0
 fann2==1.0.7
 # Also update in mycroft/skills/padatious_service.py
 padatious==0.3.7