File apcupsd-gpp.patch of Package apcupsd

This patch is required to work correctly with system tcpd.h, i. e. with
"rm include/tcpd.h".
================================================================================
Index: include/apc.h
===================================================================
--- include/apc.h.orig
+++ include/apc.h
@@ -154,7 +154,9 @@
 
 /* Pull in our local copy because the library does not have correct protos */
 #ifdef HAVE_LIBWRAP
+extern "C" {
 # include "tcpd.h"
+}
 #endif
 
 /* Solaris doesn't define this */