File 0046-configure-reduce-libseccomp-version.patch of Package qemu

From 457b3ba0559c7fefb6d84e0efc39eea5c5a70ad2 Mon Sep 17 00:00:00 2001
From: Bruce Rogers <brogers@suse.com>
Date: Tue, 26 May 2015 14:41:54 -0600
Subject: [PATCH] configure: reduce libseccomp version requirement to 2.1.0

It turns out that although the version of libseccomp used in SLE12
is in fact v2.1.1, the package has a bug where pkg-config incorrectly
reports that the version is v2.1.0. (see bsc#932372)

Adjust the configure script detection to allow for v2.1.0.

Signed-off-by: Bruce Rogers <brogers@suse.com>
---
 configure | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/configure b/configure
index b43b371..b50428c 100755
--- a/configure
+++ b/configure
@@ -1849,7 +1849,7 @@ fi
 
 if test "$seccomp" != "no" ; then
     if test "$cpu" = "i386" || test "$cpu" = "x86_64" &&
-        $pkg_config --atleast-version=2.1.1 libseccomp; then
+        $pkg_config --atleast-version=2.1.0 libseccomp; then
         libs_softmmu="$libs_softmmu `$pkg_config --libs libseccomp`"
         QEMU_CFLAGS="$QEMU_CFLAGS `$pkg_config --cflags libseccomp`"
 	seccomp="yes"